Jbraviator

Members
  • Content Count

    3
  • Joined

  • Last visited

  • Feedback

    N/A

Community Reputation

0 Neutral

About Jbraviator

  • Rank
    Newbie
  1. Turns out it was a bad coil. I replaced a coil and all 5 plugs and she runs great again with no codes.
  2. No vaccum leak that I can find. I used a Bosch MAF from Autozone.
  3. Please help me community, 2001 S60 2.5T with P1171 and P0304 codes. I bought the car and it ran fine other than a slight immediate roughness upon cold startup, but had 9 codes stored. I took it local Volvo shop and was convinced that the throttle body was bad and needed to be replaced. That should clear most if not all of the codes. $1100 later they replaced it and it did clear most of the codes, but did not affect the rough startup. The car still drove fine though. After feeling burned by that, I decided to just live with the rough start up, but now it has a rough idle almost all the time and slightly stutters under throttle loads greater than about 1/4 throttle so whatever is wrong with it is getting worse. I replaced the MAF sensor, but that didn't fix anything. I've been reading about the purge valve solenoid and evaporative canister purge valve and O2 sensor, but the videos I've watched don't look like mine. I don't see any purge valve or solenoid or anything that looks like that by the airbox or under the manifold like I've seen in videos. I want to replace the easy stuff I can before taking it back to the shop. They wanted to charge an hour ($120) labor to replace the MAF which took me no more than 10 minutes. I appreciate all your help. I fell in love with this car and really feeling like I made a mistake buying it, but it's just so fun to drive I want to fix it if possible.