boosted moose

Members
  • Content Count

    4
  • Joined

  • Last visited

  • Feedback

    N/A

Community Reputation

0 Neutral

About boosted moose

  • Rank
    Newbie
  • Birthday 08/07/1994

Profile Information

  • Gender
    Male

Previous Fields

  • Location
    Albuquerque, New Mexico

Recent Profile Visitors

514 profile views
  1. UPDATE Car is still not starting after engine swap, I need to figure out what is going on. This is one of those "crank-no-start" conditions. I checked the timing again for good measure but the vehicle is still refusing to start. I have a spare crank sensor and a spare cam position sensor I could swap out. I did indeed swap out both of those sensors before I re-check the timing but no luck; I will try again after the engine swap. I might have fried the CPS when I overheated the last motor which is the engine the sensors came from. I also wonder what the odds are that my ECU is also bad? Fuel pressure is present. Spark plugs should be getting power. The cap-n-rotor were working perfectly fine on the last car so i did not touch them but I did change the spark plug. Timing seems to be spot on. Compression on the motor was checked not too long ago but I will check again for good measure; especially after cranking with possibly bad timing (whoops). I have a spare cylinder head I can rebuild if it comes down to it. It sucks that the ECU is not giving me any codes, it would be nice to know why it is refusing to start (especially if it has compression). Maybe I have a bad ground somewhere? It can't be a ground for the spark but maybe it has a bad ground for the ECU or fuel injectors thus causing the fuel injectors not to fire. I plan to check each spark plug for spark and to update the cap-n-rotor. If that does not work, I will take the intake manifold off and re-check the grounds and also refresh any other grounds for good measure.
  2. I figured I would document my wrenching adventures as I have been wrenching exclusively on both RWD and FWD Volvo's for several years now to pass the time (and money). I test drove a cheap 1995 Volvo 850 turbo on craigslist and became addicted to boosting in a T5, the car was faster than I thought it would be (honestly). I bought the car, my first 850 turbo, for $900 from this chick who dented the left-front fender, broke the left-front fender, and a loud tick coming from the motor (which later turned out to be a bad A/C compressor.) All was looking alive and well for this car, I even scored an identical matching fender from another Volvohead for $25. I bought another matching mirror from Ebay also. Everything was great until Christmas day when a coworker gave me his gift by nailing it with his 1500 Silverado doing a all sorts of damage worse than what I started out with in the first place. I cut my losses, parted out the car, kept the running motor (I had even installed a Continental timing belt and water pump kit that only saw about 10,000 miles). I began to hunt for another cleaner (and physically unmolested) Volvo 850 but a sedan this time, I had been getting the itch for a cleaner 850 I can start doing some tasteful performance mods to. I was getting desperate in finding a rust-free 850 in my area of New Mexico at a decent price. I got in contact with a seller in Phoenix, Arizona who was selling a clean Volvo 850 sedan who's daughter ended up overheating and killing a week before, so lucky me? Not really. I ended up taking advantage of my California trip and picked up a clean "reliable, low-mile" 850 sedan. The vehicle looked in really good condition, inside and out; this is definitely one of the cleanest Volvo 850's I have seen lately. I test drove it good, everything seemed fine so I ended up coughing up $1350 for it considering its condition. I tested the car around the LA area before taking the plunge and attempting to drive it back to my hometown of Albuquerque 10 hours away. Everything seemed to check out.....until I started to get close to the CA-AZ border and the car started to overheat. Big whoop, I was crying about the cost of getting the car back home than the actual condition of the car itself. I don't think the owner knew but the motor had been opened up before considering the sloppy black goop sandwiched between the sections of the engine block. The spark plugs were also numbered from 1 to 5 so I could tell no genius was not under the hood any time recently. I didn't want anybodies sloppy seconds on this motor anyways so I began to swapping the motor right away. The old motor will get salvaged. The donor motor was leaky so I changed as many seals as I could on the block including the front main seals, front camshaft seals, oil thermostat seals, and rear main seal. I also had purchased a 15G turbo from another 850T a while back and rebuilt it with a 15G rebuild kit from Amazon which I swapped into this donor motor. The engine is now dropped in, everything is connected. The car now has a crank-no-start condition. Fuel pressure is present but I have yet to check for spark. If spark is present, I will re-check the timing. The engine was spun by hand after redoing the timing on the motor so I might be off by a tooth. I hope to report back to the blog with some success.