Sign in to follow this  
lookforjoe

Hussein's 1998 V70 Xr : The Force Awakens

Recommended Posts

Brilliant. Loved the vid btw lol.

Out of curiosity, where are you planning to go with this? Looking at the constant stream of performance improvements the project seems to be halfway down the slippery slope!

At this rate you'll be sleeving a block before christmas.

Share this post


Link to post
Share on other sites

Brilliant. Loved the vid btw lol.

Out of curiosity, where are you planning to go with this? Looking at the constant stream of performance improvements the project seems to be halfway down the slippery slope!

At this rate you'll be sleeving a block before christmas.

Thanks. I'm trying to get Dave to YT the vid from VCNA, I can't even watch it on my old Macs.

I'm not sure where I'll end up with this. Once I get VEMS set up, I presume I will be able to extract more out of it. However, even as it is, I have torque steer once again & the car is getting pretty far from a comfortable DD. My daughter doesn't want to ride in it again, too loud, too harsh, etc. I think my son-in-law got a little car sick coming back from the airport, and I was being careful not to accelerate hard, etc....

I really want a Gripper diff for the M66 AWD, it's apparently in the works. I also want to get to the drag strip, just to see what kind of 1/4 runs I can do, without launching hard, of course.

Share this post


Link to post
Share on other sites

Looks like you are slowly turning this into a weekend/fun car to me, instead of a DD :)

I already have that car

x19Carlisle3jpg.jpg

I can't have two that serve that purpose......

Share this post


Link to post
Share on other sites

Thanks. I'm trying to get Dave to YT the vid from VCNA, I can't even watch it on my old Macs.

I'm not sure where I'll end up with this. Once I get VEMS set up, I presume I will be able to extract more out of it. However, even as it is, I have torque steer once again & the car is getting pretty far from a comfortable DD. My daughter doesn't want to ride in it again, too loud, too harsh, etc. I think my son-in-law got a little car sick coming back from the airport, and I was being careful not to accelerate hard, etc....

I really want a Gripper diff for the M66 AWD, it's apparently in the works. I also want to get to the drag strip, just to see what kind of 1/4 runs I can do, without launching hard, of course.

In regards to the bolded statement from above...

I was getting to a point where I was pretty happy with the setup I had with my Volvo being my summer time DD, and the Acura TSX (my other car), is what I would mainly drive in the winters, and when we have shitty weather during the summer, or when I feel like driving something that is at least economical on gas... 700kms (400+miles) to a tank with the TSX vs 450kms (280miles) with the Volvo, I know I know, it comparing apples and oranges. The thing is whenever I drive my TSX for any amount of time, I actually really miss my Volvo, and cant wait to drive it... till yesterday....

I took my father in law out to test drive some cars, and naturally being the last of the good weather days I took my Volvo, and we were looking at Range Rover Evoque and Volvo XC60. I drove and picked him up, and then drove to the Range Rover/ Land Rover dealership, so far so good, I enjoyed my volvo like I always do. We took an Evoque and and LR2, the Evoque was beautiful and a great ride, the LR2, was a big pile... We were at that dealership for about 1.5hrs. Get back in the Volvo and drive out to the Volvo dealership. This drive wasn't as enjoyable, something about having to talk to an older guy (father in law is in his late 50's) and you could tell the louder than stock exhaust was starting to annoy him, and slowly me, as I was straining to hear him, as he's not a loud guy...

We spent over 2hrs at the Volvo dealership, and the XC60, may not have been as flashy but it more than helds it own, actually the ride was so enjoyable that got me wondering, do I really need two cars, one to have fun in and one for the practical days??? couldn't a new S60 satisfy both? 325BHP, and 350+TQ along with bettter fuel economy than the Volvo, not quite as good as Acura, but like most things in life its compromise...

I actually started thinking of doing a complete sweep, by trading in both my cars for the new S60, and trade in my wifes car (Acura RDX) for the new XC60...

Anyways I leave the Volvo dealership, and the drive back to drop off my father in law, wasn't enjoyable at all. I figured, just wait till I drop him off and I can turn my music up, and just punch it in 2nd or 3rd that will erase any worries, and sadly it didn't...

My kids who are about 4 and 5 think my volvo is a blast, a part of me cant wait till they are older where they can articulate their thoughts a bit more, and another part of me dreads that day, as one of them may give me the same kind of response, as what you got above from your daughter...

I know my wife has always hated it, so that I'm used to that, but the kids well that would start making the volvo justifiable a little tougher to do...

The drive today was mor enjoyable, but I can't deny I still have an itch... Maybe its because I have run out of projects to do on the Volvo... Hussein, I think I just discovered your obsession with constantly changing and tweeking things on yoru ride...

So for rambling...

Either way I'm glad you got the FPR issues resolved, as JCViggen had pointed out, the larger volume shouldn't affect pressure, it may affect the response time as your rising rate pressure regulator changes from vacuum to atmosphere to boost, but realistically with the total volume that your fuel rail would have, again that isn't likely either, you would need a massive volume for that even to be a factor... good luck with getting VEMS on there and getting this thing on a dyno and then later on, down the track...

  • Upvote 1
  • Downvote 1

Share this post


Link to post
Share on other sites

So recognizable...

I went to the Volkswagen and Volvo dealership last weekend as I can choose a new lease car for the company that i work for. I can drive it privately as well if I want to, it will cost me about $200 a month and that includes insurance, unlimited miles, no maintenance costs, etc. The 850 costs me +- $600 every month for insurance, gas, road tax and that excludes maintenance.

But, I never thought that I would find a car that would suit my needs. But...the new Volkswagen Jetta 2.0 tsi (GLI in USA I think) has a good 252 bhp once chipped by ABT, nice 18" wheels, full leather interior, sport chassis, etc.

Driving that + saving me probably $6k+ a year..I must be crazy to say no!

And the Jetta drove really nice...

(and no hussein, i wont place Volkswagen pics in your thread ^_^ )

Share this post


Link to post
Share on other sites

Let's not get too warm & fuzzy about alternative DD's :-)

I'm sure you realize I have no intention of giving up the XR, I love driving every day, the ONLY proviso is when we have company that requires using the wagon.....

Since I have to "tinker" with whatever car I drive, I'm thinking a C30 AWD makes sense down the road to replace the V70, and that will take some planning & research, primarily regarding the software requirements.

Share this post


Link to post
Share on other sites

Pulled the IC & added a diverter to help even out the flow through the IC - Treadstone does this, so I figured it is worth a shot before I shell out for a larger/higher density IC.

Used a piece of IC piping

IMG_1513.jpg

welded in place

IMG_1514.jpg

lower air intake, while bumper is off

IMG_1515.jpg

IMG_1536.jpg

Did a 1-3rd pull, temp rose 20º. Didn't realize I wound it out so far in first, some of what is wheel spin, I guess - the indicated road speed jumps suddenly.

Picture5-4.png

Picture6-2.png

I'll see how it goes in 3rd/4th tomorrow. If I still see a 30º approach, I'm going to go with the Treadstone TR-1235. I already sectioned the bumper bar again to allow for a 3.5" core depth.

Share this post


Link to post
Share on other sites

^, yeah - I didn't mean to run it up that high. I have no rev-limiter/cut, it only works at 7600, not when you raise it to 8K

3rd/4th log. IAT's still rise about 25º, so slight improvement with the deflector, but not enough. I really do need to add a IAT at the turbo outlet to datalog what temps I have going to the IC, that would give me a better sense as to whether I could expect much of a difference with a higher density IC

Picture8.png

Picture9.png

short 4th pull

Picture10.png

Picture11.png

I replaced the LMA-3 today with a used unit, so I can log EBP again. I also rewired the EGT probe in the #4 runner to the LMA-3, so I can get more accurate EGT's when logging. When I shifted into 4th in the above log, the gauge showed 1400ºF, not the 1150ºF shown by the probe in the dump tube. Somehow I lost the IAT in the process, so I have to look at that tomorrow.

I raised the WOT sliders over 6800, and enriched the top three load cells for 6800/7200/7600 to see if it drops the EGT's

Share this post


Link to post
Share on other sites

Very impressive 60-120 time! Did you get the ME7 IAT sensor calibrated correctly or are you still using the GM one? When you mention the IAT's still rise 25°, are you talking above ambient temps?

Share this post


Link to post
Share on other sites

Holy hell H, 9340rpm! jesus christ im buying cams for my motor, i have to hear what this thing sounds like at 9k :lol:

btw, i keep forgetting to grab my ecu and pull the config, ill try and remember, let me know if you really need it asap and ill get my ass in gear :tup:

  • Upvote 1

Share this post


Link to post
Share on other sites

Very impressive 60-120 time! Did you get the ME7 IAT sensor calibrated correctly or are you still using the GM one? When you mention the IAT's still rise 25°, are you talking above ambient temps?

I got the ME7 IAT calibrated very easily, unlike the GM. As far as IAT's rising, I'm referring to the increase from part load temp to whatever it ends up at at the end of the pull(s). My cruising temps are usually a few degrees over ambient, part load IAT's are usually 5-10º over ambient. I think I need to data log hotside temps, so I can see what kind of temp I actually have coming out the turbo, that way I can get a better sense of the IC efficiency.

Holy hell H, 9340rpm! jesus christ im buying cams for my motor, i have to hear what this thing sounds like at 9k :lol:

btw, i keep forgetting to grab my ecu and pull the config, ill try and remember, let me know if you really need it asap and ill get my ass in gear :tup:

Hi Robbie - I'd like to work with the config file, so whenever you can get to it.

Share this post


Link to post
Share on other sites

Took the car to get the alignment fixed after changing the left control arm last week. Lower skirt has to come off to clear the alignment rack, so i just pulled the whole bumper, it's quicker

IMG_1528.jpg

On the way home, I did a hard 3rd pull & got a massive cloud of smoke out the back of the wagon, I let off but the cloud continued. Pretty soon I could tell it was coolant. I had a 2 mile downhill stretch, so I coasted down the highway & got off, through two green lights & into the Volvo dealer parking lot. After the smoke cleared, I found that the heater hose off the block ruptured.
The hose can be removed in about 3 minutes, fortunately it clears the turbo inlet.
They didn't have it in stock, so I got a ride home & picked up some spare hoses to make a splice until the new hose arrives Friday
Turns out the IAT & Accel logging is due a failure in the used LMA-3, I went over all the wiring & sensors, then plugged my old one back in & they both came back to life. I'll just have to look for another external MAP sensor for logging.

Share this post


Link to post
Share on other sites

Took the car to get the alignment fixed after changing the left control arm last week. Lower skirt has to come off to clear the alignment rack, so i just pulled the whole bumper, it's quicker

IMG_1528.jpg

On the way home, I did a hard 3rd pull & got a massive cloud of smoke out the back of the wagon, I let off but the cloud continued. Pretty soon I could tell it was coolant. I had a 2 mile downhill stretch, so I coasted down the highway & got off, through two green lights & into the Volvo dealer parking lot. After the smoke cleared, I found that the heater hose off the block ruptured.

IMG_1529.jpg

The hose can be removed in about 3 minutes, fortunately it clears the turbo inlet.

IMG_1531.jpg

They didn't have it in stock, so I got a ride home & picked up some spare hoses to make a splice until the new hose arrives Friday

IMG_1532.jpg

Turns out the IAT & Accel logging is due a failure in the used LMA-3, I went over all the wiring & sensors, then plugged my old one back in & they both came back to life. I'll just have to look for another external MAP sensor for logging.

Lucky. And it looks like its baring its teeth (FMIC) in the first photo. lol

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this