Sign in to follow this  
Volvo5.0

Sas (Air Pump) Delete....write-Up With Pics

Recommended Posts

I hit 50 miles today and popped the code again. I disconnected that purple vacuum line and capped it. I disconntected the pump at the clip next to the battery tray. If all of this is correct I am going to pull out the ECU and verify the position of the diode. My pump was turning on prior to doing this which tells me that the relay above the fan was working. Is there a chance that the solenoid is bad. How can I check this?

The code that I am throwing is P0410

Share this post


Link to post
Share on other sites

Ok, here is where I am at. I tested the air pump relay by switching it with the main relay, car still started.

I have the ECU in front of me right now and I did the diode off of another post that had it running from A32 to B38. I have the direction correct, but should I switch it to the way it is done in this post.

The only thing that I do not know how to test is the solenoid. I read a post under the repair section and the instructions are not to clear for me.

From what I can see, once these areas are covered I should be in the clear.

Share this post


Link to post
Share on other sites

The A32 to B38 doesnt work, that is activated when the pump signal is set. You want it on the A32 to A37 where is activates when the vacuum solenoid is set.

That's your issue, the diode is installed on the wrong pins. So reread this topic... idono how you got it on the B38...

Edited by binglax09

Share this post


Link to post
Share on other sites

I am up to a 100 miles and all is good. I have an sas ok on my reader and no check engine. This was an awsome post. Thank you for all of the help.

Share this post


Link to post
Share on other sites

What model/year cars can this mod be done on?

Share this post


Link to post
Share on other sites

in california, during smog checks, the smog person checks the sticker under the hood and makes sure that evertyhing is there....

this sticker helped me pass smog:

IMG_20101219_204425.jpg

part # 9430401

Share this post


Link to post
Share on other sites

I threw away my SAS parts like 3 years ago, can someone post pics or a VADIS diagram of the relay and solenoid? I already soldered the diode and reread the thread and realized I need to have those parts connected for this to work.

Share this post


Link to post
Share on other sites

The solenoid is #18 in the picture PN 1270389. The relay is PN 9442933 and is located in the relay box under the hood.

Airpump.jpg

Share this post


Link to post
Share on other sites

This works awesome...did it last week and fully passed emissions today..NO codes and almost Zero emissions at the tailpipe..car runs great...Takes like 5 minutes..most of that time is for the soldering iron to warm up...everyone should do this. I am going to physically remove all the non needed parts next week when i do my turbo back system...Thanks for the great info!!

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this