• Upcoming Events

    No upcoming events found

Archived

This topic is now archived and is closed to further replies.

  • 0

Emissions Fail - Obd Ii Can't Connect?

Question

Posted

So I went to get my car inspection and emissions today... inspection was fine but when they did the emissions it failed at the OBD-II port!

They said it could not read it and had to fail me.

So I thought that was weird because 2 years ago it passed fine. I went to my Volvo Indie shop and the used their handheld scanner to read the OBD-II port just fine and while the car was on and accelerator was pushed down he could read the MAF and O2 readings on this handheld scanner.

Well I took it BACK to the emissions location and they said it failed again because it could not read. OK, well then I took it down the street to another place and it FAILED also!

I am so confused. I dont have a check engine light or service light or anything. Why am I failing saying that they cant read the emissions through the OBD-II connection. Two places, failed both places :(

Please help, I need to get this resolved fast so I can get my registration in.

Thanks!

0

Share this post


Link to post
Share on other sites

48 answers to this question

Posted

I guess I should add that since then I did get a IPD Tune from Lucky... would that have any affect on my OBD reading?

Lucky can you chime in on this?

0

Share this post


Link to post
Share on other sites

Posted

I wonder if they are saying they can't connect, when the problem is that they can't get OBD monitor info. Can't connect would probably be a wiring issue, OBD monitor could be the tune.

0

Share this post


Link to post
Share on other sites

Posted

Dave,that's what I was going to say, contact IPD, or get another stock ecu swap it in and see what happens.

0

Share this post


Link to post
Share on other sites

Posted

Ok, I sent Lucky a link to this thread.

I got the tune from Lucky directly out of his wife's car... not from IPD... even though it is an IPD tune.

It just pisses me off that I paid 28$ to go to another place to get tested

-2

Share this post


Link to post
Share on other sites

Posted

If you have an OBD scanner you can try to connect with that. It should also be able to tell you what monitors are active and such.

0

Share this post


Link to post
Share on other sites

Posted

If you do need a scanner look up my topic on scanners. I can give you a dropbox link with the correct software for both an ELM327 connector and the VAG-Com connector.

Although, it looks like using a stock ECU is the ticket to pass here. Although you would have to take the time to set all the readiness which can be a PITA!

0

Share this post


Link to post
Share on other sites

Posted

He same thing happened to me.

Ipd stage 1 in my car as well.

Luckily the smog guy just did it manually abd let me pass. Even with the Ipd turboback kit.

I was curious as to why the obdii couldn't connect as well.

0

Share this post


Link to post
Share on other sites

Posted

Ok, looks like I need a stock 850R tune... ugh anyone have one I can "rent"??

-1

Share this post


Link to post
Share on other sites

Posted

Ok, looks like I need a stock 850R tune... ugh anyone have one I can "rent"??

Doesnt need to be an R tune. Just any turbo ECU that meets your vehicles requirement, as in SAS, EGR and so forth. Buy a used one and keep it around, not expensive.

1

Share this post


Link to post
Share on other sites

Posted

Doesnt need to be an R tune. Just any turbo ECU that meets your vehicles requirement, as in SAS, EGR and so forth. Buy a used one and keep it around, not expensive.

Ok, I think a guy on TB is looking for one for me.

I am saying 96-97 850 Turbo (T5 or R) ECU with NO SAS and NO EGR... any other things to specify?

0

Share this post


Link to post
Share on other sites

Posted

When we went a couple weeks ago they said 96 Volvos don't do an obdii test. We asked why (we didn't think we pass with the exhaust test) and they just said that's what the computer says. So it might not be an Ecu issue, maybe its an issue with the emissions scan tool or something. Who knows, they did it the same way 2years agi. Somehow we passed despite all the smoke.

0

Share this post


Link to post
Share on other sites

Posted

When we went a couple weeks ago they said 96 Volvos don't do an obdii test. We asked why (we didn't think we pass with the exhaust test) and they just said that's what the computer says. So it might not be an Ecu issue, maybe its an issue with the emissions scan tool or something. Who knows, they did it the same way 2years agi. Somehow we passed despite all the smoke.

I think VA is 25 years old car is eligible

0

Share this post


Link to post
Share on other sites

Posted

Sometimes Motronic 4.x have problems setting readiness and getting a read from emission station software. Check your states emissions laws/regs..Some states exempt later 850s and the 98 s70 from OBD testing.. In Ohio they gave me the tailpipe option and I passed it just fine (if you are worried about passing TP, pour 90% isopropyl alcohol in gas tank with @ 3gallons of gas, you WILL pass)

0

Share this post


Link to post
Share on other sites

Posted

Sometimes Motronic 4.x have problems setting readiness and getting a read from emission station software. Check your states emissions laws/regs..Some states exempt later 850s and the 98 s70 from OBD testing.. In Ohio they gave me the tailpipe option and I passed it just fine (if you are worried about passing TP, pour 90% isopropyl alcohol in gas tank with @ 3gallons of gas, you WILL pass)

Tail pipe was fine, it was is the OBD-II could not read. I dont believe there is an option for either or.

0

Share this post


Link to post
Share on other sites

Posted

have you checked the fuse for the obd ll connector?

0

Share this post


Link to post
Share on other sites