Sign in to follow this  
Che'_Moderator

Volvo Takes Pole Position

Recommended Posts

Lexington, Ohio (Aug 5, 2011) – K-PAX Racing, the World Challenge GT Manufacturers’ and Drivers’ champion in 2010, enjoyed a solid day of qualifying at round seven of the Pirelli World Challenge Championship at Mid Ohio, with three out of the four of the teams cars qualifying in the top three in both the GT and Touring Car classes. Read more: http://volvospeed.com/index/kpax_volvo_racing_midohio_2011.html

  • Upvote 1

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Dovydas
      Hello everyone,
      I am trying to convert my volvo 850 2.0 T5 to motronic 4.4, and I got some questions :
      1. Are these the correct opening time values for orange bosch injectors (-785):
      5.00 2.632 5.99 2.632 6.97 2.632 8.03 2.398 9.02 1.853 10.00 1.443 10.99 1.170 11.48 1.111 11.97 1.014 12.47 0.936 13.03 0.858 13.52 0.819 14.02 0.760 14.51 0.722 15.00 0.683 15.99 0.605
      Because there are some other values posted in the comments section on 4.4wiki page (check out the photo).
      2. When I set the injector opening time to 0,683 for 15.00V, tunerrt program automaticly changes it to 0,682, is it okay? All the other values doesn't change, stays as typed.
       

    • By cryptophilosopher
      selling a set of s60r wheels 18"/7" great condition, straight center hub was bored to 65.1 mm for use on my 98 v70  will fit any volvo with a 65.1 hub or smaller. $800
       
      selling remote fobs, these are all new in box .  the battery's may need to be replaced $25
      i work at a former Volvo dealer and these were some of the inventory left behind 
       
      launch x431 scanner , lightly used  looks new i have all parts and papers, im the original ower and can transfer ownership to you with launch. upgrade able software. matco  sells these scanners now
       
      have original volvo scanner for 96-2000 volvos  v70, s70 ,850 , 740, 960, and others in that time frame. can be used for code reading, date and key programing.
       
      willing to ship, shipping on fobs is $10   the scanner and wheels i need to get a estimate   crypto currency  bitcoin  accepted. email me cryptophilosopher@gmail.com parts are located in concord california












    • By blackc30probs
      2008 Volvo C30 1.0 T5 with 130k miles.
      On cold startup the car runs rough bouncing between 1500-2000 rpm for about 10 sec before returning to 1500 until it is warm, the following codes have appeared: P0101 MAF circuit range/performance, and P0300 Random/ Multiple cylinder misfire. I have taken the following steps to solve the issue:

      About a year ago Cylinder 3 coil pack was replaced due to P303 code (issue was solved, just added as background)
      New MAF sensor was installed (after attempting to clean the stock Bosch unit, which also didn’t stop the code from reappearing) 2 weeks ago
      All 5 spark plugs replaced with Bosch units (3 months ago)
      New air filter, which was installed at the same time as the spark plugs

      The MAF problem started about a month ago, but the rough idle only 2 weeks ago, even after clearing the codes, they return after 1 or 2 driving cycles. Rough start up even happens after codes are cleared. 

      Anybody had this issue, or have any advice as to what the next steps should be?  
    • By kaseke
      Hello all, 
      maybe someone can help me or give me the instructions. 

      I have 2010 year Volvo XC60, 2.4 diesel, D4 engine, automatic transmission, AWD. 

      Problem is for some reason the car does not have turbo boost anymore. Turbo is working only after the cold start 80 km/h and then turns himself off. If the engine temperature is 90C, ignition needs to be off at least ~ 10 minutes and then turbo works again but only up to 80 km/h. And then turns himself off again. 

      At first I had problem with turbo which leaked oil, the bottom part of the engine was all oily. Second problem was smoke in the interior and under the bonnet. Smoke came from rear part of the engine, not from exhaust! No power loss, car went very well. 
      Local service they changed turbo to the new one (used but factory restored) and installed the new turbo. Oil leak was goen but smoke remained. Smoke came same place, under the bonnet, from rear part of the engine where is the turbo. I went back to the service and they did guarantee works. Uninstalled turbo and sent the turbo to the seller, who checked that everything was okay. Before the repairman started to install turbo again he discovered broken plastic tube / pipe which connects two turbos with each other. And I think this was the problem why engine sometime smoked. Also in the service they washed DPF filter. I have not any idea why because with this car I have not any problems with DPF and it worked before the service very well. 
      Ok turbo and tube were installed, at the beginning car works. Suddenly threre was not turbo boost any more. 
      No fault codes / lights in the dashboard. Diagnostics does not show any fault codes. Car is not smoking and starts up well but after the first approx. 300 meters turbo pressure is gone.
      MAP sensor is working, EGR is working, turbo valve /controller (flap) is working. No smoke from exhaust. 
      I suspect that maybe they ruined in service DPF filter or DPF filter temperature sensor. I have no idea how they did this task and this was the task which I have not ordered from him. 

      Any ideas? 
       
    • By littledove
      I am having troubles finding information on the name of a part that I need to replace.  It's a part of maintenance to my 1995 Volvo 850 Turbo 2.3L.  I want to order it and replace it since its cracked.  If I don't know the name of it I cant order it.  It's under the fuel rail and plugs (elbow rubber ends)into the manifold then the line extends to the throttle body tree near the vacuum lines.  The color of the line is yellow except for the elbow rubber ends. It's about a foot in length.  Does anyone know what the exact name for this so I can order it online?  

      I had to put electrical tape on the elbow end of the tree so that's what you see.