Tightmopedman9

Tuners Rejoice! Free Tuning For M4.4!

Recommended Posts

21 hours ago, dirtzuk said:

so my 96' 960 has a 0 261 203 654 and according to the net it is infact a m4.4 ..  it would be lacking hardware to run boost control?  it would be very cool if i could use this ecu along with the 960 coil packs on a b5234t 

There is already a mod available to run coil packs on a B5234T M4.4 ecu.  It involves a little hardware modification but is probably easier than trying to modify the 960 ecu to run boost control.

Have a look at Piet and Venderbroek's posts for more info

Edited by bomb192uk

Share this post


Link to post
Share on other sites

OK, so I'm finally getting around to putting together a "base" tune on the hybrid -607/-936 bin for the wife's '97GLT. I'm taking the -607 that Piet put the -936 AC routines into as the start, and transferring some base values from the -936 bin to get us something to begin with.
@Turboforslund put together the XDF from the -936 chip that I sent him, which was awesome.

Looking over things, the first thing that stands out are a couple extra RPM axes in the -936. 

RPMaxes.jpg[/img]

axiscompare.jpg[/img]

As you can see, the RPM value ranges are different, and he notes their possible usage in the first pic.

Comparing a couple of the charts for the affected maps

valuecompare.jpg[/img]

 

Should I worry about trying to add/change those axes in the bin I'm putting together, or just leave them as the fixed major RPMs?

The "start" point for the tune is an '01 LPT motor, Japanifold w/ 16T and exhaust, and blue injectors. (No COP or ExVVT yet)

Maybe leave the fixed Major RPMs and alter some of the values in the other RPM ranges on the -607 to match the -936 stuff?

Thoughts?

Links to the -936 bin and the XDF
XDF
936 BIN

Edited by Chuck W

Share this post


Link to post
Share on other sites

On a x70 NA ecu, all you have to do to get boost control to work is remove one resistor and add 2 zero ohm resistors, I imagine it’s the same on a 960 ecu. I have a high res scan of a 960 ecu so will try and look at it later.

Share this post


Link to post
Share on other sites
On 7/10/2019 at 8:53 AM, Avinitlarge said:

On a x70 NA ecu, all you have to do to get boost control to work is remove one resistor and add 2 zero ohm resistors, I imagine it’s the same on a 960 ecu. I have a high res scan of a 960 ecu so will try and look at it later.

Nice and easy then

Share this post


Link to post
Share on other sites
On 20.06.2019 at 09:09, Calvin Sonnik said:

Bang Bang? lub więcej trzeszczenia decel? Oto jedno, które zrobiłem ... Przepływa około 800-900 KG / h podczas huku bang. To musi być piekło dla zaworów wydechowych.

 

 

 

Mam XDF niedługo zakończony TM
Powinien mieć to i kilka innych gadżetów.

 

I want to get a pop bang effect when the turnover decreases. what you did is nls.

This is pop bangs

 

Share this post


Link to post
Share on other sites

Has anyone successfully got pops, bangs and flames by using the launch control antilag .bin? 

 

If so what settings did you find best to use? 

Share this post


Link to post
Share on other sites

Having trouble communicating to the ECU. I flashed the bin just fine but am not able to connect for logging. Using a KKL cable straight to the serial port on my toughbook, no adapter. Tried realterm as the wiki suggested and it will not open the port.

Share this post


Link to post
Share on other sites

The logging needs to be enabled by sending a code to the ecu (as you may have read).

You say you are using a serial port? Is that as in old school 9 pin D connector serial port? Have you selected the port correctly in tunerpro?

Usually the code is sent from tunerpro to the ecu when you click connect.  Which ADX file are you using (what is the filename)?

To use realterm you need to make sure you have the correct com port selected and change the baud rate.

Share this post


Link to post
Share on other sites
15 minutes ago, bomb192uk said:

The logging needs to be enabled by sending a code to the ecu (as you may have read).

You say you are using a serial port? Is that as in old school 9 pin D connector serial port? Have you selected the port correctly in tunerpro?

Usually the code is sent from tunerpro to the ecu when you click connect.  Which ADX file are you using (what is the filename)?

To use realterm you need to make sure you have the correct com port selected and change the baud rate.

Yup, that's the old school DB9. I am using the rev5.ADX, does the XDF need to match because I am currently using the rev6.xdf.

These are my current settings, I matched what the wiki said.

It's funny, when I click the "Test for a Valid Interface" button in TunerPro It say's it's valid, then the next time I click it it gives me an error. Works, Doesn't, Works, Doesn't, Works. Alternates perfectly. Like I said I can flash just fine, have done so 4 times already. Just can't connect for logging.

67172611_1137999086386045_2314894519646027776_n.png

Edited by WellThatsSurprising

Share this post


Link to post
Share on other sites

Is it possible to get a clarification on this for the auto bin? (Sorry to dredge up the old post)

Should the addresses and changes be 3D69 and 3D6A (12 88 to 00 00) and 4113 and 4114 (7D AD to 7D AE)?

Thanks!

On 2/2/2016 at 6:28 AM, Avinitlarge said:

Or disable the pre-start listener, I think its 4 values that need changing, venderbroeck did mine for me

I believe these are the differences on a manual bin, not sure if auto is the same
2016-02-02.png

On 2/2/2016 at 1:50 PM, Piet said:

Nope, they are not the same for an automatic bin!

For the automatic bin change:

@ 3C69  12 88 into 00 00

@4113  7C AD into 7D AE

 

The result of this however will be that:

-With the engine not running there will always be normal OBD functionality and no logging functionality.

-With the engine running there will be always logging functionality and no OBD functionality

 

 

 

 

Share this post


Link to post
Share on other sites
3 hours ago, bomb192uk said:

What does the 'Test for Valid Interface Settings' bring back?

This is what I get when it doesn't work. Alternatively it will give me a success message but still won't start datalogging. It seems to switch between working and not working at random. Tring to connect through Realterm@125000baud results in a parameter is incorrect error.

not working.jpg

working.png

Edited by WellThatsSurprising

Share this post


Link to post
Share on other sites
1 hour ago, WellThatsSurprising said:

This is what I get when it doesn't work. Alternatively it will give me a success message but still won't start datalogging. It seems to switch between working and not working at random. Tring to connect through Realterm@125000baud results in a parameter is incorrect error.

What operating system are you running?

Share this post


Link to post
Share on other sites

Have you tried changing the allocated Com port number in device manager?

Maybe try COM9 and change the settings to match in tunerpro

Edited by bomb192uk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.