Archived

This topic is now archived and is closed to further replies.

boxpin

Boxpin's Build

Recommended Posts

Getting new tires and noticed that the control arms are moving. Turns out those poly mounts have worn out. Lasted about a year. Replacing with Powerflex.

F984D816-027F-42DA-8313-88F6C53B6F79_zps

8FEFFD70-0C6A-4A83-88B6-0EE6D248ED7B_zps

DA1C2BEE-900E-4DD6-814D-551F3097EE48_zps

Then I spotted some extra venting on my rotor.

182735C5-57FC-4335-9EEC-6D0049299CEB_zps

Share this post


Link to post
Share on other sites

I was about to get drilled rotors, but had several people warning of them cracking on road cars. Something to do with the many cycles of heating / cooling that a daily driver gets.

Sucks about the control arm bushings. I am doing them on my wifes car at the moment (Subaru Outback), and didnt realise there was such a difference in quality when you went poly.

Share this post


Link to post
Share on other sites

Swapping the trans. Mainly because I smoked the clutch. How can one smoke a clutch with a 707? It was my first full launch with launch control. The car would not move, just roasted the clutch, How.

779D26B7-2866-4DDC-9915-7DCBF6C9439E_zps

22410455-951F-46B2-9918-AF5D234C597B_zps

7431C717-49F1-4EF5-BC39-00AA06608D28_zps

29FD0B5D-42B6-4980-BB9D-7E9D9F4C0DCF_zps

Coming soon:

89533099-F1C8-4B80-8A8C-4E28B9C381BF_zps

Share this post


Link to post
Share on other sites

What material was that disc? Looks like you need something more substantial in terms of friction material. The Spec discs rated for high output are not fiber-based. Horrible for DD in town driving though.

AP_SpecDiscs_zpsb60f2a14.jpg

My AP disc looks like it may have organic/fiber content, however

Share this post


Link to post
Share on other sites

All right, things are coming back together.

Picked up the flywheel. I had it stepped to give it some more clamping force.

Kevlar disc this time.

FBF36D3E-1122-4130-A2CE-CCA880F57CB0_zps

Replaced syncros in the new trans

9EAB4B42-050B-4B36-9C21-2348F5D0568B_zps

Swapped the quaife over... Does anyone have the torque spec for the ring gear???

B87B8F6C-8EAF-4379-9954-C1E2A010EB98_zps

A22C902F-BF10-4CAA-8263-439E01218291_zps

and this last one if for 'VS Legend tha douche'..I caved, going back to steel.

5E1460C0-047B-47D0-96F8-F4ADA4DDB761_zps

Share this post


Link to post
Share on other sites

Probably just as well. Those poly bushes looked like absolute crap. Surprised your tires weren't buggered from all that caster/camber change....

Share this post


Link to post
Share on other sites

All right, things are coming back together. Picked up the flywheel. I had it stepped to give it some more clamping force. Kevlar disc this time.

FBF36D3E-1122-4130-A2CE-CCA880F57CB0_zps

Forgot to ask - did you measure total height of flywheel & assembled clutch to confirm you haven't moved to fingers outside the normal operating window of the Slave-T/O?

Share this post


Link to post
Share on other sites

Yea, I'd be scared to cause an issues stepping it like that, realistically probably wouldn't hurt anything but you never know.

Share this post


Link to post
Share on other sites

I think that was the reason for my Southbend clutch(es) having so many clamping issues...wrong stack height. Either way; looks good John! Looking forward to videos but I'm really surprised that you smoked the clutch with the 707! Crazy torque or did you ride it too long?

Share this post


Link to post
Share on other sites

Well somebody has got some explaining to do. Before everyone goes crazy I contacted them and they were in shock and asked me to sent it back of which they will correct the issue and get it back to me immediately.

Share this post


Link to post
Share on other sites

Good catch!

Would have been a lot of work to pull that back out when it failed, plus it could cause lots of vibration that would be hard to locate

:tup:

Share this post


Link to post
Share on other sites

Well somebody has got some explaining to do. Before everyone goes crazy I contacted them and they were in shock and asked me to sent it back of which they will correct the issue and get it back to me immediately.

'>

Good thing I was bored and decided to play with the disc before I installed it.

Share this post


Link to post
Share on other sites