Recommended Posts

On 12/25/2016 at 10:29 PM, lookforjoe said:

Whose is the 500? Is it an Abarth  :blush: ?

It's my Fiances, boringiish 500 with the NA 1.4? Does better then you'd think in the snow with proper snow tires. We did just get both rear wheel bearings replaced under warranty though. Cupped the crap out of the rear wheels. Only had 4-5k on those winter tires and only 33,000 on the car itself. 

Share this post


Link to post
Share on other sites

Re-sealed the Angle gear on my '00 XC. 
Sleals.PNG
#2 is 9143885
#3 is 30735126

Left had seals 2 & 3 live very far down in the sleeve and the angle gear respectively. The transmission side was totally dry and so we decided to leave them be. 

The big seal on the exposed passenger side was the most likely culprit. 
0hZxjYOh.jpg

Cleaned up
VvsCA0lh.jpg
QDGJOidh.jpg

Filling it through a long funnel from above the engine. 

h0m2sLih.jpg

gzEQXTQh.jpg

Took about 98% of the 1L bottle. 

Driven 100+ miles on it with no leaks and no foul burning smell. 

  • Upvote 3

Share this post


Link to post
Share on other sites

FIY  -you can fill those out of the car - no fluid will leak out unless you tip it over where the vent nipple is located :)

I use a pair of long sheet rock screws to extract the inner/outer   D/S seal - but if it was dry no reason to fuck with it I agree.

Share this post


Link to post
Share on other sites
1 hour ago, lookforjoe said:

FIY  -you can fill those out of the car - no fluid will leak out unless you tip it over where the vent nipple is located :)

I use a pair of long sheet rock screws to extract the inner/outer   D/S seal - but if it was dry no reason to monkey with it I agree.

Ahh nice i did notice the hole at the top. 

We had the thing all sorts of flipped around when refitting it into the car. Should have filmed how it came out. 

A screw was needed for the large seal on the pass side. Nothing seems to work better. 

Share this post


Link to post
Share on other sites

Trying to sure up the wiring on my refurb AFR gauge. Yes the innovate died randomly after less then 5000 miles. It was the gauge that was no good. 

Looking for the correct pin to fit into the accessory connector under the dash. I had some ok ones from Carquest, however since being bought out, they carry nothing of the sort any more. Can anyone pinpoint which one is correct? 

 

Pins.PNG

Share this post


Link to post
Share on other sites

After some research and dealer questioning the correct pins are seemingly unavailable. Out of stock here in the U.S. and not show as available in Sweden. 

#27 seemed to be the correct one. 

Improvising, I did some junkyard digging into the wires under the dash and took apart some of the male side connectors for those big yellow / purple connectors under the dash. 

C3n8a8Kh.jpg

They produced some decent sized leads. Took a pair of side cutters and pinched them slightly so they fit and where held into the yellow connector. 

Happy to say as well the Innovate gauge warranty process went alright. Seems to be working correctly again. 

qk7kzB8h.jpg

Edited by apeacock
  • Upvote 1

Share this post


Link to post
Share on other sites

Nice job getting it all fixed quickly. 

That being said, I'm a huge fan of my AEM gauges - not the flashiest/most feature laden, but dead reliable and respond quickly. If it continues to be a problem, you could switch the Innovate gauge for an AEM one, they use the same LSU 4.9 Wideband O2 sensor so it would be pretty close to plug and play.

Share this post


Link to post
Share on other sites
7 hours ago, apeacock said:

After some research and dealer questioning the correct pins are seemingly unavailable. Out of stock here in the U.S. and not show as available in Sweden.
#27 seemed to be the correct one.

[...]

The pins you are looking for are referred to as:

Power Timer, Standard Power Timer, Junior Power Timer or JPT

Obviously there is a size difference between "Standard" and "Junior". Available in male or female configuration. Requires a suitable crimping tool to enable simultanious crimping of both the contact and strain relief tabs. Or just fudge it with pliers and never pull on the cable.

Share this post


Link to post
Share on other sites
7 hours ago, andyb5 said:

Nice job getting it all fixed quickly. 

That being said, I'm a huge fan of my AEM gauges - not the flashiest/most feature laden, but dead reliable and respond quickly. If it continues to be a problem, you could switch the Innovate gauge for an AEM one, they use the same LSU 4.9 Wideband O2 sensor so it would be pretty close to plug and play.

I was thinking of just getting the gauge only (if possible) The screen on this is pretty nice, and I guess it responds quicker? idk. Doing it again I would go for the problem free one. 

Did a better job wiring it all together this time too. It's not pretty but its all heat shrink / adhesive quick connects. 

 

 

1 hour ago, Blockpartie said:

The pins you are looking for are referred to as:

Power Timer, Standard Power Timer, Junior Power Timer or JPT

Obviously there is a size difference between "Standard" and "Junior". Available in male or female configuration. Requires a suitable crimping tool to enable simultanious crimping of both the contact and strain relief tabs. Or just fudge it with pliers and never pull on the cable.

I was seeing Flat terminal and terminal pin when locating similar things. I think we are talking about the same pieces. Using this in the end might have proven easier, being pre-crimped and all.

On all the ends I did 3:1 adhesive lined heat shrink to sure it up a bit.  The terminals are just in the connector under the pressure of the 'lid' they are lightly tuggable. 

Share this post


Link to post
Share on other sites

Innovate's MTX-L gauge is shit. It was poorly engineered in many ways, one of them being that they pulse the heater circuit too slowly, causing large temperature swings of the sensing element, leading to premature failure.

The new AEM X-series are worlds better, not in terms of response time and accuracy, but also sensor life. 

  • Upvote 1

Share this post


Link to post
Share on other sites
14 hours ago, Tightmopedman9 said:

Innovate's MTX-L gauge is stuff. It was poorly engineered in many ways, one of them being that they pulse the heater circuit too slowly, causing large temperature swings of the sensing element, leading to premature failure.

The new AEM X-series are worlds better, not in terms of response time and accuracy, but also sensor life. 

I have a feeling that's part of what changed in the Firmware update & Warranty repair. It's on "htr" much longer then it used to be, which I'm really fine with so long as it all works from now on. The 02 sensor came back really clean and with new sleaving on the cable, they may have replaced it as well. 

The X series is so thin too, kind of nice if you want to mount it somewhere nontraditional. 

Considering Scaling back the A pillar clutter with a single gauge to do both AFR & Boost. 

Share this post


Link to post
Share on other sites

Sitting a little more neatly now. took the time to hot glue down the leather cover and trim the thicker sections on the seams 
kkhKJuih.jpg

Quintessential R badge affixed to the front of the grill. Got another junkyard one and gave it a clean with 3-4 plasti dip coats. 

Badge is done with 3m red. Clips remain intact. 

bSHe49hh.jpg

  • Upvote 3

Share this post


Link to post
Share on other sites

Love that boot, dude.

Share this post


Link to post
Share on other sites

Instead of getting the battery turned sideways I decided to make a little helper bracket to hold the intake system off the B+ cable. 

This piece of bar stock was going to be a holder for my rear Ohlins reservoirs. I found an old thread on Swedespeed that shows a longer piece going  between the two seat belt mounts for a 3rd row. 

RUrT5z0h.jpg
EQWkuzZh.jpg
jcx1WM9h.jpg

Pictures from Gdog16 on SS:

MUbaw7Bh.jpg
zVxDgWTh.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By andyb5
      Here's the story behind my new-to-me 2000 V70 R. Its gonna be a long post, and picture heavy too!
      This thread will serve as a continuation of sorts of my 1999 V70 R build, which can be read here:
       
      The conclusion to that thread will come later this summer, as I will be pulling all the modifications of my 99 R, and transferring them to the 00 R.  Now, onto the details of my new Venetian Red 00 R!
      My friend sent me the for sale ad on Facebook:

      Here's a couple of the photos from the listing:


      After spending a few weeks negotiating with the seller, I bought a one way flight to Denver, packed some tools in my bag (I did, however, forgot to pack underwear ) and went to visit some friends before picking up a car and driving it 1900 miles across the country back to New York!!!
      I landed in Denver Friday evening (May 12) in the early evening.  While there, I got to check out the murals of the Denver Airport, and see all the other bits that are the basis for a long list of conspiracy theories.

      Here's how it sat when I picked it up from the seller at a shopping center a short walk from my friends apartment.

      Shortly after taking delivery of my R, I went on a hike in up Golden with my friends.  The views were stunning to say the least.


      After lots of fun touring around the Denver area on Saturday, I packed my stuff into the car and started driving back to NY on Sunday morning (May 14th) with plans to stop at my friend's place in Cedar Falls, Iowa.  Here are some photos from the drive Sunday.  Nebraska was wide open, flat, and very easy to drive through:


      Drove through miles of turbines in Iowa (despite the picture being of a singular turbine).  There's a Don Quixote joke here somewhere....

      Cruising towards Cedar Falls, Iowa and got to watch the sun set


      Sunday's drive was about 800 miles, which took about 12 hours, and the drive home was off to a great, relatively easy start.
      Here's how my car sat outside my buddy's place in Iowa on Monday morning

      When I left Iowa Monday morning, my destination was headed to Anthony's (@apeacock) house near Buffalo, NY.  Monday held about 850 miles of driving, which was about 13 hours of driving.
      Stopped for gas in PA.  I had a hard time with card reader on the pumps though....

      Made it to Anthony's around 10pm, took him for a quick test drive, and then face-planted into the extremely comfortable bed in his guest room.
      Monday morning before I left his house, Anthony took this photo of our wagons together

      Made good time on my way back to Troy on Tuesday morning - at this point, 300 miles seemed like a short drive to me   I got to enjoy some really nice views in the mountains in western NY:

      Here's how the odometer when I made it home:
       
      The entire trip was 1960 miles, and I managed an average of 26.8 mpg at an average speed of 70 mph.  All of this was calculated from the trip computer. 
      And here's how my two wagons sat when I got the office on Tuesday at noon:

      Earlier tonight I got it registered in NY, so now the build can begin.  Stay tuned, this should be a fun project and I'm very excited to get working on it  
    • By cryptophilosopher
      98 99 00 01 02 03 04 VOLVO S70 S40 S80 V40 KEYLESS ENTRY KEY FOB OEM

      https://www.amazon.com/VOLVO-S70-S40-KEYLESS-ENTRY/dp/B01M28NQXR/ref=olp_product_details?_encoding=UTF8&me=
    • By cruzvolvo
      T-5R Wagon (1995), black, automatic transmission, mostly original with a few moderate suspension upgrades. Approximately 175k, with careful and regular service. This was a California car for most of its life, and is (from best estimates) one of fewer than 100 still on the road in the U.S. It comes with: IPD 3" cat-back exhaust; 4 steelies with snow tires mounted; trailer hitch; original parts no longer installed; and your choice of body panels and parts from a 1995 black 850 NA wagon (parts car). I am a motivated seller and will take $3,000, for the next two weeks. Contact me and I'll answer all questions, to the best of my knowledge, and send any additional pictures that you may want. The car can be seen in Delaware, near I-95. 

       
       
       
       
       
       
    • By WarmCanadianWinters
      SO
      Just made an account, hello all
      Tryna do some work on my '98 V70R, the timing belt is from 2006 I think, rear brakes are sitting at 10% (So sayeth the local mechanic).
      Gonna pick up the Power Stop Z23 Performance D/S Rotor and pad kit. Couldn't find any note in the service records of the rear calipers ever being replace, (and the first guy who had this car put nearly 18 grand into it) does it need to be done? 
      Also is this timing belt a problem? From what I've read, if it breaks, its a bad time :(
       
      Thanks all in advance. Pretty green to mechanic-ing
      Oh shitters, I posted it twice. Off to a bad start
    • By WarmCanadianWinters
      SO
      Just made an account, hello all
      Tryna do some work on my '98 V70R, the timing belt is from 2006 I think, rear brakes are sitting at 10% (So sayeth the local mechanic).
      Gonna pick up the Power Stop Z23 Performance D/S Rotor and pad kit. Couldn't find any note in the service records of the rear calipers ever being replace, (and the first guy who had this car put nearly 18 grand into it) does it need to be done? 
      Also is this timing belt a problem? From what I've read, if it breaks, its a bad time :(
       
      Thanks all in advance. Pretty green to mechanic-ing