Sign in to follow this  
dougy

dougy's 300$ C70

Recommended Posts

thanks, even though its non functional lol i still like the look better than what it came with...maybe if im bored ill connect it, but really  its pointless . 

 

2_zps8qa8wzr4.jpg

 

 

1_zpsoxp0ioyc.jpg

 

  • Upvote 1

Share this post


Link to post
Share on other sites

5000 miles later C70 runs great, only problem i have to fix is with the top... all windows use to go down and up when you put the top down or up and my defrost does not work...so it must be the relay for the defrost...put  Porsche calipers with s60r rotors on it and thats about all. 

 

1._zpshmr3ljhi.jpg

 

 

2_zpsn6ofdvzq.jpg

 

 

3_zpstcq4g93z.jpg

 

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Looks good, but why's your engine oil dipstick all askew? Hack. :biggrin:

Just kidding, looking good as always!

Share this post


Link to post
Share on other sites
On 7/22/2016 at 6:44 PM, B_Dub said:

Looks good, but why's your engine oil dipstick all askew? Hack. :biggrin:

Just kidding, looking good as always!

lol...thanks.

 

On 7/23/2016 at 10:55 AM, apeacock said:

might do the same with my R intake cover. I've got the line but it's so much taking stuff apart to make it work. 

 

 

Share this post


Link to post
Share on other sites

sure...

 

 

Share this post


Link to post
Share on other sites

thanks Justjim98

 

rear R breaks upgrade. 

1_zps6hpz6tne.jpg

2_zpsqocgzmiw.jpg

3_zpspfxwp8ec.jpg

  • Upvote 2

Share this post


Link to post
Share on other sites

oil change...now im at 85k ..it sure paid off to blueprint this engine...:biggrin:

 

ISiT1ki.jpg

 

5000 miles since last oil change. 

Share this post


Link to post
Share on other sites

since last time ... c70 is at 88k...runs great...lill sqeeky sound is coming from timing belt area which could be WP bearing, tensioner ect..ect..it was all used so who knows...no leaks yet. 

put on external trans oil cooler and bypassed it going through the radiator...relocated horns...cooler was in my attic, it was from kia mini van, if i remember correctly.  

 


ulOTPid.jpg

MKrFJU5.jpg

0HyCTHG.jpg

 

O28RnId.jpg

 

 

smduESE.jpg

 

7RzGHPt.jpg

 

 

0X6Nmyp.jpg

Share this post


Link to post
Share on other sites

any details on that hose connector? Did you weld it or just press fit?

Share this post


Link to post
Share on other sites
13 minutes ago, Tightmopedman9 said:

any details on that hose connector? Did you weld it or just press fit?

chopped up oem JY pipping and fitting from radiator and trans welded with stainless...i only did one on c70 just to do the flush in the future. 

all others i did both like this

DSC02304.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this