Archived

This topic is now archived and is closed to further replies.

Chrisonfire

IPD Lowering Springs P80 850/S70/V70 - NEW!

Recommended Posts

For sale is a pair of brand new front and rear IPD lowering springs for P80 Volvos. I originally bought them for my 99 S70, but never installed them and eventually sold the car. Also included is a brand new pair of upper spring seats.

Looking to get $200 locally - or willing to negotiate a price+shipping if you are not in Western Washington. I understand these are on-sale at IPD right now, so I am negotiable.

Thanks for looking

 

IMG_20170819_185051.jpg

Share this post


Link to post
Share on other sites

  • Similar Content

    • By carson3
      Hi all! I'm looking for a recommendation on what to do with this classic car!
      This bad boy has 106,250 miles on him and has his fair share of nicks, dings, and minor bruises. The right front sidemarker assembly lens is missing and sometimes starts in 3rd gear on extended drives.
      Is there any Volvo enthusiast that would fix this guy up? I'd love for it to go into good hands instead of trading it in! 😀

    • By JPittVolvo
      So i have been dealing with the oil cooler lines on my 1998 V70 Awd Turbo for a while. Vehicle has 169,000 miles or so on it now and since i have gotten the car i have put two sets of oil cooler lines on it. I have used the OEM lines each time with new seals etc. Well the second set is now leaking again from the connection at the rubber hose to metal clamping as the usually seem to start leaking at. I dont want to have to do a third set of lines or have these ones rebuilt. I was able to get a hold of the NA motor oil cooler block off plate that it uses instead of having oil coolers. Does anyone know if that would cause a big problem if i decided to put that on instead of new lines? The car is daily driven to work and back about 2 miles on local roads. Never take it on the highway etc, we use the wifes newer mini van for that. I am just worried that iuf i do the block off that the oil might be too high a temperature and burn out the turbo etc. Any thoughts would be greatly appreciated?
    • By n8t50
      Hi folks, looking for some help with a misfire/sputter on a 1998 V70 N/A (537xxxkm). Car was throwing some codes for the rear O2 sensor, but wasn't doing anything funny. Coming back from a camping trip, it started to misfire/sputter while cruising at 100km/h in 5th gear. It then started stalling out while at idle. I replaced the rear sensor, and shortly after, it started to throw codes for the front O2 sensor (slow response, and lean mixture), and do the same thing.
      It is fine on startup, but sometimes will have little fits of stalling at idle, and sputtering/missing when accelerating/cruising. When it would stall, I used to be able to get it too restart on the first try, but now it usually takes 2-4 cycles of the ignition to get it to catch. Once I give it some gas and take off, it improves a little, and just seems to lack a little power. When at idle, you can also smell the exhaust, which normally is very clean.
      Today I replaced the front O2 sensor. The car ran well for 30min, then threw the same codes, and started acting up again. I've tested the PCV and the compression, and both are fine. The spark plugs are new, but the rest of the ignition system (Coils, leads, rotor) are older. I'm thinking this sounds like either an ignition system problem, or a fuel system. I'm not sure how to run the normal relay test, because it it is really intermittent with its sputtering/stalling. (Currently there seems to be about a 50/50 chance of it being fine, or acting up when I take it out) I'm probably going to redo the ignition system, because the car needs it anyways, but am wondering what else this could be.
      Thanks guys!
    • By cryptophilosopher
      98 99 00 01 02 03 04 VOLVO S70 S40 S80 V40 KEYLESS ENTRY KEY FOB OEM

      https://www.amazon.com/VOLVO-S70-S40-KEYLESS-ENTRY/dp/B01M28NQXR/ref=olp_product_details?_encoding=UTF8&me=