Archived

This topic is now archived and is closed to further replies.

Chrisonfire

IPD Lowering Springs P80 850/S70/V70 - NEW!

Recommended Posts

For sale is a pair of brand new front and rear IPD lowering springs for P80 Volvos. I originally bought them for my 99 S70, but never installed them and eventually sold the car. Also included is a brand new pair of upper spring seats.

Looking to get $200 locally - or willing to negotiate a price+shipping if you are not in Western Washington. I understand these are on-sale at IPD right now, so I am negotiable.

Thanks for looking

 

IMG_20170819_185051.jpg

Share this post


Link to post
Share on other sites

  • Similar Content

    • By getscandi
      What’s up guys! 
      I’m looking to buy a used 240mm 850r/early x70 pressure plate, p/n 272 218
      i have a local shop that is willing to rebuild it for me with beefier diaphragm for more 00mph ! 
      Cant find locally here im Montreal Canada, so seller must be willing to ship to Montreal! 🙏🏼
       
      Thank you
       
      brick on 🧱🌪🇸🇪🦌

    • By 9UPpbH6Cp
      Hello there!
      I'm going for my first subject, I recently bought a Volvo V70 from 1999, but I crashed the front…

       
      I managed to get all the needed replacements parts, but I can't reacht he 3 bottom bolts on the front section

       
      On the video we can see it better on why this is hard-to-reach: https://i.imgur.com/2PRsmaB.mp4
      All pictures are on imgur, and I already asked a bit on reddit. I didn't find any YouTube video about it and it seems this is pretty similar on Volvo 850s, S70, C70 of the 90s.
       
      Thanks very much!
       
    • By lotsofmagnets
      Hey folks, 
      Turns out long time lurker 1st time poster. Figured this would be the place to go with a pretty specialised problem as the m4.4 people are here. 
      Backstory:
      This is the car I've owned for 12 years now:

      it's not super sexy but it's mine. i have a 164TE, 1800E, 2 C202s and another almost identical 850 except a wagon (very early production 93 model also)
      It started life as a 2.0 20V auto which is not bad if you're prepared for the tacho to visit 3PM frequently but through circumstance I got a B5254S and an M56 from a 2.0 (4.45 final drive) and that made the car actually faster than I anticipated. I drove it like that for 6 years but the engine was tired and blowing more smoke than I was comfortable with. About 3 years ago a valve chipped so I threw another head on and drove it for another year but then the week before I was scheduled to fly out to Australia for 2 months it chipped another valve and so I decided the time had come. I already had a B5244T3 sitting aside and I had already rebuilt a 16T turbo for it so last summer I finally put the car on blocks in the backyard and ripped the engine out. Over the winter I did a stage zero on the B5244T3 and rebuilt the steering rack while I had the subframe out to fix a leak and also got access to a full 98 xc70 so took everything relevant to the M4.4 setup from it and worked it onto the B5244T3. Finally, this May just gone I had everything ready and started putting the car back together and after working slowly on it the past 2 months On Thursday I was finally ready to turn the key for the 1st time. My 1st actual attempt to start it failed and so I did checks and the 1st thing I found was that the injectors only pulse for about a second  before turning off but then when I release the key an injector or 2 fire once. This happens every time I crank. I tried several very short cranks and the car actually fired up! I ran it for about 20 mins and after about 5 mins the lambda light came on but there's no surprise there as there are no o2 sensors yet as there is still no exhaust and the ecu is an auto one so that might also have thrown the code but the car did run for about 20 mins but then i turned it off and so far haven't been able to get it running again.
      This is how the engine bay looks right now:

      So, I think if you've read this far you can probably figure what my question is but I'll ask anyway: Would anyone have an idea what's going on? To recap, when the car is cranking, the injectors fire for maybe a second then stop but then when I stop cranking an injector or 2 may fire again. I've checked power to the ecu and on cranking I get 10.4V which I guess should be enough and I cleaned all of the contacts between the battery and ecu quite well so I don;t think it's an issue of power. Things I'm about to do are check spark to see if I lose spark too or just injectors and then maybe throw a cam sensor and crank sensor in desperation but I'm hoping someone has either encountered this before or has enough of an idea of how the M4.4 system works to help me figure this out. BTW I do have a video of it happening but not sure how to post it here. But yeah, If you have any questions about converting a 2.0 NA auto car to a turbocharged manual then feel free to ask  
    • By Gachet
      Hi all, good evening
      I’ve got a 850 Turbo 1994 and want the upgrade the turbocharger. I’ve been looking in some forums, specially here, and found out the the TD04HL-16T are basically plug and play with some differences in the flange.
      My doubts still remains in the flange diference: will I be able to retrofit my 15G flange in the 16T without further changes?
      I have found a V70 T5 HPT with B5234T3 engine and I’m about to buy its turbocharger.
      Thanks in advance, cheers from Brazil!! 
    • By LouisvilleR
      SOLD
       
       
       
       
      Car has been parked for 8 months or so due to soft brake pedal. Possibly needs master cylinder, also needs struts and shocks to be safe drivable aside from just getting it home. Selling as 5-speed swap/donor motor. You can start it and hear it run if you bring a battery. 
      I have some records from the previous owner (she bought it from her father in law nearly new and owned it up until I bought it about 3 years ago). I've done most maintenance myself since I've owned it. The car was in a minor fender bender about 2 years ago, replaced front driver fender and bumper. You can see from the pictures. Plenty of road wear and bumps and scrapes in the paint as you'll see in the pictures. I can provide interior pictures upon request, still needs to be cleaned and vacuumed as I was driving it regularly. Rear door panels are torn up from dog transport. Front seats and parts of the back seats would be useable as dark leather swap, no woodgrain trim.
      Maintenance I'd do if I was keeping it - Rear interior door panels (dog damage) Rear seat (dog damage) CV Boots Shocks and Struts all around.
      Extras:
      Rough condition (but straight) Perfos
      Thule Rack included, with one Thule bike tray and off brand kayak racks.
      IPD Rear Overload Springs
      Car has factory Volvo CD changer in the trunk. Not hooked up, no idea if it works, although I have no reason to assume that it doesn't.
      Currently selling WHOLE car only. Located in Louisville, KY. $650. Title in hand.