Archived

This topic is now archived and is closed to further replies.

Recommended Posts

Hey guys, 

Recently my car has been shooting me with "reduced engine performance" and "engine system service required" Error codes. Yesterday I tried to replace the throttle body on the car thinking that was the problem. Once I tried driving it the acceleration was still the same very slow, and didn't go past 60 mph. So now I'm taking the other throttle body back since that obviously wasn't the problem. I'm wondering if its and issue with the turbo instead or even the air intake. Has anyone else had these issues? Please let me know. 

Share this post


Link to post
Share on other sites

Post up some OBD2 codes. Ah, who am I kidding, this thread's already a month old with no activity...

Share this post


Link to post
Share on other sites

  • Similar Content

    • By DB855R
      2004 Volvo S60R MT 58k
      $8,000 Black with Gobi leather Every option except headed front seats and Navigation. All original no mods. Originally titled in Texas 3 owner car. After 19k car was bought by Stadel Volvo in East Petersburg Pa. Car was a certified per owned car when purchased by my father (2nd owner) Have window sticker. Throughout his ownership Volvo did all required maintenance. All brakes, rotors and pads were replaced prior to extended warranty running out. I purchased the car at 51k.  Since then Volvo replaced 2 rear hubs and did 4 wheel alignment. (Steering wheel they never centered it) At 54k I flushed the power steering fluid. I added IPD R style boost gauge.  All 4 tires were replaced with new Pirelli All season tires all have less then 2k. Custom wood insert with hinges was made for trunk to accommodate a full size spare. All 5 rims are 18x8 pegs with Pirelli tires 4 rims were painted dark grey (Have 18x8 bright silver pegs on my 740 if the grey color wasn’t for you) Also have original factory donut  Painted front grill black Car has carpet and formed rubber floor mats for front and rear   Minor accident Audi SUV brushed passenger front quarter fender Insurance paid for fender to be buffed out and resprayed to match total insurance cost was $1700 still have receipt   Great car, beautiful car not even a door ding in body. Issues: The display will show alarm service needed sometimes I don’t know why it locks and alarm works. Sometimes passenger window if u press up it will go up and come down about 1 inch Serpentine belt and tensioner and timing belt and tensioner are due to be replaced next year. Car is not close to replacement by milage but both are only 15 year belts.    Please note I can change the belts for right buyer it’s $350 in parts I’m asking a lower price knowing belts need future change    Only reason car has so little miles I have 7 vehicles Only reason for sale I have 7 vehicles  call or text: 5 seven 0 - 7 zero 9- four 33 nine. U can PM me but I’m rarely online         


































    • By Dovydas
      Hello everyone,
      I am trying to convert my volvo 850 2.0 T5 to motronic 4.4, and I got some questions :
      1. Are these the correct opening time values for orange bosch injectors (-785):
      5.00 2.632 5.99 2.632 6.97 2.632 8.03 2.398 9.02 1.853 10.00 1.443 10.99 1.170 11.48 1.111 11.97 1.014 12.47 0.936 13.03 0.858 13.52 0.819 14.02 0.760 14.51 0.722 15.00 0.683 15.99 0.605
      Because there are some other values posted in the comments section on 4.4wiki page (check out the photo).
      2. When I set the injector opening time to 0,683 for 15.00V, tunerrt program automaticly changes it to 0,682, is it okay? All the other values doesn't change, stays as typed.
       

    • By cryptophilosopher
      selling a set of s60r wheels 18"/7" great condition, straight center hub was bored to 65.1 mm for use on my 98 v70  will fit any volvo with a 65.1 hub or smaller. $800
       
      selling remote fobs, these are all new in box .  the battery's may need to be replaced $25
      i work at a former Volvo dealer and these were some of the inventory left behind 
       
      launch x431 scanner , lightly used  looks new i have all parts and papers, im the original ower and can transfer ownership to you with launch. upgrade able software. matco  sells these scanners now
       
      have original volvo scanner for 96-2000 volvos  v70, s70 ,850 , 740, 960, and others in that time frame. can be used for code reading, date and key programing.
       
      willing to ship, shipping on fobs is $10   the scanner and wheels i need to get a estimate   crypto currency  bitcoin  accepted. email me cryptophilosopher@gmail.com parts are located in concord california












    • By Bosozoku_Volvo
      as the title says, im looking for a useable t5 engine AS COMPLETE AS POSSIBLE in the socal area. willing to drive to pick up. 
       
      im also cool with leads on an engine in your local Clist or Yard. 
    • By kaseke
      Hello all, 
      maybe someone can help me or give me the instructions. 

      I have 2010 year Volvo XC60, 2.4 diesel, D4 engine, automatic transmission, AWD. 

      Problem is for some reason the car does not have turbo boost anymore. Turbo is working only after the cold start 80 km/h and then turns himself off. If the engine temperature is 90C, ignition needs to be off at least ~ 10 minutes and then turbo works again but only up to 80 km/h. And then turns himself off again. 

      At first I had problem with turbo which leaked oil, the bottom part of the engine was all oily. Second problem was smoke in the interior and under the bonnet. Smoke came from rear part of the engine, not from exhaust! No power loss, car went very well. 
      Local service they changed turbo to the new one (used but factory restored) and installed the new turbo. Oil leak was goen but smoke remained. Smoke came same place, under the bonnet, from rear part of the engine where is the turbo. I went back to the service and they did guarantee works. Uninstalled turbo and sent the turbo to the seller, who checked that everything was okay. Before the repairman started to install turbo again he discovered broken plastic tube / pipe which connects two turbos with each other. And I think this was the problem why engine sometime smoked. Also in the service they washed DPF filter. I have not any idea why because with this car I have not any problems with DPF and it worked before the service very well. 
      Ok turbo and tube were installed, at the beginning car works. Suddenly threre was not turbo boost any more. 
      No fault codes / lights in the dashboard. Diagnostics does not show any fault codes. Car is not smoking and starts up well but after the first approx. 300 meters turbo pressure is gone.
      MAP sensor is working, EGR is working, turbo valve /controller (flap) is working. No smoke from exhaust. 
      I suspect that maybe they ruined in service DPF filter or DPF filter temperature sensor. I have no idea how they did this task and this was the task which I have not ordered from him. 

      Any ideas?