Archived

This topic is now archived and is closed to further replies.

MyBrickIsSlow

New to me 06 S60 T5 M66 problems

Recommended Posts

So I picked up another of Chilledman's half finished projects. I am trying to get this thing sorted out for Carlisle and have hit a dead end. There are two issues that I am trying to iron out.

   First the sunroof will not function. I have checked the alarm module and it seems to work fine.  Unplugging it does not make a difference. I can hear the sunroof control module click when the switch is moved, but no signs from the sunroof motor. What is the next step to troubleshoot this? Honestly I never use the sunroof on my cars, but the drains are clogged in this one which is a major issue.

   Second the trunk will not open with the trunk release or the key. I have ohmed out the harness and applied 12v directly to the lock solenoid and both are good. Power is where it should be but is not being delivered when the microswitch is activated. I also tried swapping the harness and lock mechanism with a known to be good one with no luck. I can not locate the fuse or relay for this. Any help would be appreciated.

 

Share this post


Link to post
Share on other sites

Yes. But I am unsure which one it is. After spending some time with the trunk wiring today I was able to jump the wires within the harness and function the lock solenoid. So I don't think the fuse is bad.

Share this post


Link to post
Share on other sites

I'd say it's time to pull up a wiring diagram. Find out what's between the release and the actuator that could prevent it from unlocking.

Share this post


Link to post
Share on other sites

So i have the trunk sorted out. It was a faulty wire and a failing microswitch.

 

I also found that the sunroof motor was disconnected. I plugged it in and it seemed to work. But now it fully opened in the slide position. When you then attempt to close it it stops about 3 inches short. This happens when position 1 or 2 of the switch is used. I have attempted to do all of the "resets" I have come across, 5 lock and unlocks with the key in the door and also the ignition, also pulling the fuse while in motion. I am unable to do the regular calibration as the SR will not close.

Share this post


Link to post
Share on other sites

Yeah, I'd try to do a calibration. I had to do that to get the automatic windows working properly on our '07 XC90 V8.

Share this post


Link to post
Share on other sites