• Upcoming Events

    No upcoming events found

Archived

This topic is now archived and is closed to further replies.

  • 0

Trouble Code P0455

Question

Posted

I tried changing my gas cap, but this code reemerges once a week or so. Any suggestions? Should I try changing the Evap canister? Or should I just pony up the $600 to replace the whole pump assembly from IPD?

0

Share this post


Link to post
Share on other sites

0 answers to this question

Posted

Anyway to just trick the sensor that reports the status of this system?

0

Share this post


Link to post
Share on other sites

Posted

You have a gross leak. The car runs a test after it is warmed up and about 12 minutes after start up. It tries to run the test until the ignition is shut off, every key cycle.

If the gas cap is on correctly, then you need to find out why the test fails. Could be lots of thing. A hole in one of the lines cause a critter chewed through it, could be a bad Canister purge valve(also called the EVAP valve).

0

Share this post


Link to post
Share on other sites

Posted

Oh yeah on our blazer a freaking animal chewed the lines on that... what a pain in the butt. It could be something completely unrelated like rich said the gas cap. You woudlnt think about that but it can throw codes because the system thinks there is a problem

0

Share this post


Link to post
Share on other sites

Posted

Hehe, reminds me. On our Honda, a rat got up inside the engine compartment and made it's way over to the serpentine belt area. This is when the car was like almost brand new. So anyways, someone went out and started the car and the sound was something like "squeak squeak, thunk, clunk" and then the engine died. Apparently, the little booger was chewing on the serpentine belt when the car started. It got towed to the dealer and they denied our warranty stating that "Honda Motor Co. cannot be held responsible for small creatures causing damage to the vehicle". Hehe, OK.

Now, to address the problem, Jeff, you didn't buy an aftermarket gas cap, did you? We've tried those before and they always trigger the check engine light.

0

Share this post


Link to post
Share on other sites

Posted

It's warmin up ..."Critter Season"....man can those ground hogs be destructive little bast#rds!...Did you replace the gas cap with a factory one or a Pep Boys special. Like Rich stated you have a huge leak

0

Share this post


Link to post
Share on other sites

Posted

I replaced it with a local auto parts gas cap. Damnit.

0

Share this post


Link to post
Share on other sites

Posted

I cured my P0455 on my wife's 98 V70 by cleaning up the dents on the filler neck caused by hitting it with the gas nozzles.

Also, I cleaned the purge valve, it is located on the top left side of the fan shroud.

0

Share this post


Link to post
Share on other sites

Posted

I spent 2 hours looking for the "Purge valve" last night. I read reports that it's located right under the air intake tube. I need some kind soul to take a picture of their purge valve and it's location so I know where and what it is.

0

Share this post


Link to post
Share on other sites

Posted

I have 1 Volvo.

How about telling us what year and model?

0

Share this post


Link to post
Share on other sites

Posted

How about telling us what year and model?

1998 S70 T5.

0

Share this post


Link to post
Share on other sites

Posted

OK the below link shows where the purge valve is but yours will look different, more square than the one in the Pic.

EvapValve.jpg

0

Share this post


Link to post
Share on other sites

Posted

Ok, yeah, I looked at that thing quite a bit, since it was in the proposed location. But attempts to follow the lines coming out of it proved to be fruitless. Where's the evap canister that the line leads too? Should I mess with the valve? Replace it? Or what?

0

Share this post


Link to post
Share on other sites

Posted

I'd replace that valve before going further, they are known failure items.

0

Share this post


Link to post
Share on other sites

Posted

I'd replace that valve before going further, they are known failure items.

Ordered one from FCP Groton. About $60 after shipping. This combined with the "known failure" ABS module is not making for a great first month of ownership. :angry:

0

Share this post


Link to post
Share on other sites

Posted

My S80 is giving me the same code. Might be the gas cap. but I was running the AC when the code first came on. Would this have anything to do with it?

0

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.