Sign in to follow this  
RobT5M

Static on P80

Recommended Posts

Morning guys,

Hoping someone has had or dealt with this issue that can possibly help.

Almost since ive had the S70 (98) I've always had static with the headlights on, when you turn them off, the static goes away. 
Same with if I turn on the rear window defrost, if its on, its static on some channels and goes away once off.

Looking for some suggestions on possible causes and things to chase down to remedy this situation.

Share this post


Link to post
Share on other sites

either some wires are crossed somewhere or it's a ground somewhere.

Share this post


Link to post
Share on other sites
6 minutes ago, flyfishing3 said:

either some wires are crossed somewhere or it's a ground somewhere.

Whelp this should be fun to try and find lol.

Im guessing it would be a body ground near the antenna?  
I need to pull some carpet out to upgrade the wiring to the fuel pump so mineaswell pull a bit more and check that while im in there.

 

Share this post


Link to post
Share on other sites

being that it happens when something is turned on, makes me think its a crossed wire.

Share this post


Link to post
Share on other sites
1 hour ago, flyfishing3 said:

being that it happens when something is turned on, makes me think its a crossed wire.

You know what... Now that you say that, im wondering, ive never gone over the wireharness im using for the aftermarket radio, still using the same one billy had in the car when I bought it like a decade ago.

Guess its time to look into that. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this