98 S70. Speedo off running 215/45/17 tires.


Recommended Posts

My car came with 205/50-17s on it and I changed to 215/45-17s but found that the speedo is off +10 at 60 (actual 70).  I know that the tire size can be compensated for with the volvo tool but is there any way to find out with vol fcr or any other tool what my current tire size is showing?

Link to comment
Share on other sites

There is less than a 2% difference between the diameter of those tires, which is only 1 or 2 mph at 60.  Also, the 215/45 is shorter, so you would actually be doing 58 or 59 at 60 indicated on the speedometer, not over.  That is assuming it would read correctly with the 205/50 tires.

I would say you have something else wrong if your speed is off that much.

Link to comment
Share on other sites

Yeah and my fuel gauge is off a quarter tank.  Changed the level indicator and still the same.  I am thinking bad cluster but the car only has 72000 miles on it and I sure dont want to change to a 200k cluster.  Is there anything else I could check?

Link to comment
Share on other sites

17 hours ago, Zappo said:

Did someone change the Odometer gear and not put the needles back on correctly?

 

This happened to me. Well, it didn't happen TO me...I myself put the needle on incorrectly on my gauge when I swapped in blue gauge faces. Should it not be put back on so that it rests on the little post near zero mph? 

My speedo is off about 6mph at highway speeds but I can't be bothered to fix it...

Link to comment
Share on other sites

I am not sure.  I did mine, but the only thing that is a little off is my RPMs.  That is why I suggested it as a possible reason.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.