Samco Horror


Recommended Posts

So I'm driving my C70 around town on a beautiful day when my low coolant light comes on. I am in the center lane at a stop light and can't get over. Next my oil light comes on and the car stumbles. I immediately shut it off as the temperature gauge redlines. Fortunately there are three state troopers on the corner waiting to direct traffic for the race at Lowes Motor Speedway. One pulls behind me with his lights on and two of them help push my car out of traffic into a nearby parking lot. I pop the hood and there is no immediate sign of trouble... no smoke, no smell. The coolant resevoir is empty but there is no sign of coolant on the motor, except for a small puddle under the lower coolant hose. I examine the hose, a brand freakin' new Samco hose, and it is split open on one side... not good. The cops offer to get a wrecker, but I told them I'd wait until the car cooled off and add some coolant and see if I could drive it the half block to a AAA service center. They wished me luck and went back to traffic control.

I waited until the temperature gauge went down to about half and added some anti-freeze that I bought at the Walgreens where I was stranded. I emptied an entire gallon into the reservoir. I then tried to start the car, hoping I could drive it the 300 yards to the service center.... no luck, wouldn't start. THAT CAN'T BE GOOD!! I ended up calling a wrecker and having it towed to the closest Volvo dealership. They offered to stay late and try to fix the car. After we got it there, the tech had me try to start it while he listened. Again, the car wouldn't start so I ended up leaving it there for them to look at on Monday. I'm thinkin' VMS at this point!!

I'll keep you posted on what is wrong, but I've got a bad feeling about it! I have no idea why the Samco hose ruptured. It looks like a razor cut, possibly from packaging or maybe I hit it with a box cutter when I opened the package, who knows. It took a while for it to burst... I checked everything out after changing the hoses to make sure i didn't have any leaks. But, Ive always said, if you want to play, you've got to be able to pay!!

jwm

Link to comment
Share on other sites

  • Replies 65
  • Created
  • Last Reply

was the temp already redlined when you noticed something wrong? Sounds like your head gasket may be toast since it doesnt start...you didnt check the oil (or plugs) for water?

If your engine emptied itself of all its water your water temp sensor wouldnt be registering much either though...

Link to comment
Share on other sites

was the temp already redlined when you noticed something wrong? Sounds like your head gasket may be toast since it doesnt start...you didnt check the oil (or plugs) for water?

If your engine emptied itself of all its water your water temp sensor wouldnt be registering much either though...

I'd been driving on the interstate for 10 miles or so without any hint of trouble. I always keep my eye on the temp gauge and it didn't rise until I was at a stoplight. When the car stumbled I knew there was trouble. I didn't have any tools with me to check the plugs. The oil looked a little darker than I thought it should... it was fresh Mobil One. The tech at the dealership said that he wanted to pull the plugs Monday so I'm guessing he suspects the same thing.

jwm

Link to comment
Share on other sites

I'm extremely sorry to hear of your trouble-- Although it sounds grim, you've gotta keep your fingers crossed at this point. Best of luck when you hear the news on Monday.

This incident brings up a potentially harmful issue w/ Samco. I guarantee people w/ Samco hoses are gonna freak just a bit about this one, I know I would.

Link to comment
Share on other sites

Sorry to hear the bad news. I hope it's not too bad. I do have to say that your attitude is refreshing given the potential $ bill.

Good luck...

JC

I know that anytime you play with a car something can go wrong. I just never thought it would be a stage 0 item! :blink:

Link to comment
Share on other sites

This incident brings up a potentially harmful issue w/ Samco. I guarantee people w/ Samco hoses are gonna freak just a bit about this one, I know I would.

you are over reacting, it is not the end of the world if the owner cut the hose by mistake.

Link to comment
Share on other sites

you are over reacting, it is not the end of the world if the owner cut the hose by mistake.

I agree. I would think this is isolated. Could have happened in packing, shipping, or unpacking. I'll know when I get the part off the car to see what the rupture looks like. On the car it looks like a slice that probably wasn't all the way through, but deep enough to weaken the hose. i don't think it's a cause for alarm.

jwm

Link to comment
Share on other sites

I agree. I would think this is isolated. Could have happened in packing, shipping, or unpacking. I'll know when I get the part off the car to see what the rupture looks like. On the car it looks like a slice that probably wasn't all the way through, but deep enough to weaken the hose. i don't think it's a cause for alarm.

jwm

I'm sure you're right and it's just an isolated incident, Samco does put out a nice product.

Link to comment
Share on other sites

Sorry to hear this. Headgastket is prolly gone. I had the same problem happen to my 01 C70. Head gasket blew out the back and the head was warped also it caused a valve seat to go bad. Let me know if you are interested in a motor we would love to have your business. PM me if you want more info. Anyways im sorry to hear this and let me know if i can be of any help in any way.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.