Archived

This topic is now archived and is closed to further replies.

maiku

Haven't Posted Pics In A While

Recommended Posts

Since the Evolution meet didn't allow for "oohhs and ahhh's", i'll post some pics here.

washed right after the drive home from kirkland

IPB Image

finally painted the bezel black, looks nicer on the car. *brownie points if you notice the 5-spd*

IPB Image

omfg! is that another pipe!?

IPB Image

IPB Image

18T. w00t.

IPB Image

Still working on some issues with turbo, hopefully within the next few weeks.

I don't like these large spikes.

IPB Image

and i know there will be haters for the dual pipes

but i love them!

Share this post


Link to post
Share on other sites

Mike, your car looks soooo much better then it used to :tup: Sorry I couldn't check it out more at the show, damn volunteer duties had me busy until the moment we left.

Share this post


Link to post
Share on other sites

now lets switch

Share this post


Link to post
Share on other sites

:o Nice rims! What did you do with the other set you had on? Nice tail pipes too :).

I'm also really liking the screen in the car, it looks like it's from the factory!

Share this post


Link to post
Share on other sites

IMO those pipes stick out just a little bit too far - look awesome, but just a little far out. Definitly like the rims - specifically the colour. Sweet lookin car overall.

Share this post


Link to post
Share on other sites

:o Nice rims! What did you do with the other set you had on? Nice tail pipes too :).

I'm also really liking the screen in the car, it looks like it's from the factory!

The other rims are on the 850, which suffers from much rub

and i like how the screen turned out

with a bit more time, i could round out the imperfections and make it look better

IMO those pipes stick out just a little bit too far - look awesome, but just a little far out. Definitly like the rims - specifically the colour. Sweet lookin car overall.

the tips do stick out a bit more than i'd like

still have to find a way to fix that

and i'm having some coolant issues

i think the hose from the expansion tank to the turbo is not tight enough

Share this post


Link to post
Share on other sites

nice!

but whats with one outlet having a lip on the rear bumper and the other not?

Share this post


Link to post
Share on other sites

nice!

but whats with one outlet having a lip on the rear bumper and the other not?

Haha, that's gonna be fixed pretty soon.

Share this post


Link to post
Share on other sites

Personally, I think your tail pipes are too long. Nice touch screen.

Share this post


Link to post
Share on other sites

nice!

but whats with one outlet having a lip on the rear bumper and the other not?

i got the wrong part number

going to get the right one soon

Share this post


Link to post
Share on other sites

good job homes. now if only you weren't canadian, everything would be so much better.

Share this post


Link to post
Share on other sites

why is Canadia bad?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.