Jump to content



Squeaking Sound From Front End..


This topic has been archived. This means that you cannot reply to this topic.
6 replies to this topic

#1 Guest_Guest_Leo_*_*

Guest_Guest_Leo_*_*
  • Guests

Posted 01 March 2007 - 02:08 AM

w=i changed my struts to bilstein touring. im getting a loud squeaking sound when i drive slow wit hbumps or make a turn with bumps. can my ball joints be going bad? I tightened everything up new links new bearing /strut tower mounts still the same problem.



#2 macmom

macmom

    Level 1 Member

  • Members
  • Pip
  • 128 posts

Posted 01 March 2007 - 02:32 AM

QUOTE(Guest_Leo_* @ Feb 28 2007, 09:08 PM) View Post
w=i changed my struts to bilstein touring. im getting a loud squeaking sound when i drive slow wit hbumps or make a turn with bumps. can my ball joints be going bad? I tightened everything up new links new bearing /strut tower mounts still the same problem.


I had the samething happen on my 95 850 when we did the suspesion with bilsteins and TME's back in 2000 it eventually will go away just the new stiffness.
2001 V70 T5 82,225K, manual trans, black with graphite interior
RIP sold 95 855 GLT 255k manual trans, bilstein/TME, IPD sway bars, Slater's end links, engine block toast, all else good. Black w/tan leather, 3rd seat, arm rest booster seat in back.
1980 VW Pick-up CUTE ALL GLORY TO THE HYPNOTOAD TRUCK
FOR SALE 1986 K5 Blazer (husband's money pit) BAD ALL GLORY TO THE HYPNOTOAD TRUCK


NOTE:Automatic transmission models have 15ft/lbs less torque

#3 Serge

Serge

    Level 6 Senior Member

  • Vendor
  • 11,118 posts

Posted 01 March 2007 - 02:44 AM

Spring mounts replaced? Check for play.

Serge - 95 850 T5
Koni Yellows ST ECU @ 17psi Orange LED Dash Custom Dimmer LED Brake Lights TSX HID Projector Retro R-bumper Carpc Hella Raintronic
Posted Image


#4 Guest_Guest_Leo_*_*

Guest_Guest_Leo_*_*
  • Guests

Posted 02 March 2007 - 02:02 AM

its been a year nd still the noise..how long till it breaks in?

#5 Serge

Serge

    Level 6 Senior Member

  • Vendor
  • 11,118 posts

Posted 02 March 2007 - 03:50 AM

QUOTE(Guest_Leo_* @ Mar 1 2007, 09:02 PM) View Post
its been a year nd still the noise..how long till it breaks in?


Check your spring mounts, sway bar links, everything. Make sure everything is tight and solid.

Serge - 95 850 T5
Koni Yellows ST ECU @ 17psi Orange LED Dash Custom Dimmer LED Brake Lights TSX HID Projector Retro R-bumper Carpc Hella Raintronic
Posted Image


#6 erikv11

erikv11

    Level 4 Member

  • Lifetime Supporter
  • 3,404 posts

Posted 02 March 2007 - 06:57 AM

when my car did that it was because the spring seats were ruined. After one year running TC's.

check out this link

'95 R 854 - 180 k

'98 V70 GLT 15g rev5b - 230 k

'96 NA 855 - 124 k  |  '98 NA S70 - 173 k

gone: '96 NA 850, '98 NA V70


#7 BrickLayer

BrickLayer

    Level 1 Member

  • Members
  • Pip
  • 27 posts

Posted 02 March 2007 - 07:46 AM

I just fixed this problem on my 850 yesterday. and I use fix very loosely.what I did to stop the squeeking is spray the top of the suspension in the engine with a heavy duty lube. squeek is gone. but now I can hear the ticking in my engine..... you win some you loose some! now if they they had a can to fix that! but do not take this as a perminant fix. it is mostly likely your spring seats. and should be replaced. it helps on the ears though.
1996 850 na 200k






Copyright 2013 Volvospeed