Archived

This topic is now archived and is closed to further replies.

  • 0

Squeaking Sound From Front End..

Question

Posted · Report post

w=i changed my struts to bilstein touring. im getting a loud squeaking sound when i drive slow wit hbumps or make a turn with bumps. can my ball joints be going bad? I tightened everything up new links new bearing /strut tower mounts still the same problem.

0

Share this post


Link to post
Share on other sites

6 answers to this question

Posted · Report post

w=i changed my struts to bilstein touring. im getting a loud squeaking sound when i drive slow wit hbumps or make a turn with bumps. can my ball joints be going bad? I tightened everything up new links new bearing /strut tower mounts still the same problem.

I had the samething happen on my 95 850 when we did the suspesion with bilsteins and TME's back in 2000 it eventually will go away just the new stiffness.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Spring mounts replaced? Check for play.

0

Share this post


Link to post
Share on other sites

Posted · Report post

its been a year nd still the noise..how long till it breaks in?

0

Share this post


Link to post
Share on other sites

Posted · Report post

its been a year nd still the noise..how long till it breaks in?

Check your spring mounts, sway bar links, everything. Make sure everything is tight and solid.

0

Share this post


Link to post
Share on other sites

Posted · Report post

when my car did that it was because the spring seats were ruined. After one year running TC's.

check out this link

0

Share this post


Link to post
Share on other sites

Posted · Report post

I just fixed this problem on my 850 yesterday. and I use fix very loosely.what I did to stop the squeeking is spray the top of the suspension in the engine with a heavy duty lube. squeek is gone. but now I can hear the ticking in my engine..... you win some you loose some! now if they they had a can to fix that! but do not take this as a perminant fix. it is mostly likely your spring seats. and should be replaced. it helps on the ears though.

0

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.