Sign in to follow this  
scout01

What Did You Do To Your Car Today.

Recommended Posts

Had to use my new jump box to jump start the car at the airport parking lot.  It has a power drain somewhere that I haven't tracked down yet.  

However, in this case I left a map light on for 5 days and it was totally dead.

Share this post


Link to post
Share on other sites

Finally installed that rear O2 sensor I bought last year. lol

Hopefully that keeps the CEL from coming back on!

Share this post


Link to post
Share on other sites

Swapped the race wheels onto the car.  Autocross tomorrow.

 

  • Upvote 2

Share this post


Link to post
Share on other sites

Fan shroud mod and installed all d088 stuff

 

 

 

 

  • Upvote 2

Share this post


Link to post
Share on other sites

Raced it.  Fun course today as well.

 

  • Upvote 3

Share this post


Link to post
Share on other sites

Pulled the front of the S40 parts car off. Got the engine/transmission/front subframe removed. M66, shifter and cables are ready to go in my car 

98173443-AEC7-43F2-B431-385C97EFE3B8_zps

  • Upvote 3

Share this post


Link to post
Share on other sites

On my R:

IT STARTED!

With the 540i MAF and GT500 Injectors first fire it ran great! Had a lot of ticking/lifter noise that eventually went away but 0 leaks. No issues. Will start to do some logging soon.

Feels so good to finally get the R on the road and to my own house/garage!

  • Upvote 3

Share this post


Link to post
Share on other sites

Put my new black carpet in.. Along with an adjustable clutch stop, new clutch arm bushings, un-installed my vintage soundstream amp ( some bridging issue) so now I have to make a new custom amp board for my JL 500/4. 

Reassebled my fuel rail and put a new 4 bar FPR on along w new vac line. Just have to put it in the car

 

only 50,000 more things to do before it's done

Share this post


Link to post
Share on other sites

Pulled the front of the S40 parts car off. Got the engine/transmission/front subframe removed. M66, shifter and cables are ready to go in my car 

98173443-AEC7-43F2-B431-385C97EFE3B8_zps

On my R:

IT STARTED!

With the 540i MAF and GT500 Injectors first fire it ran great! Had a lot of ticking/lifter noise that eventually went away but 0 leaks. No issues. Will start to do some logging soon.

Feels so good to finally get the R on the road and to my own house/garage!

​+1,000,000 to both these posts :tup:

Share this post


Link to post
Share on other sites

Replaced the fuel pump. I hated cutting my floor open but its running.

Well I still need to add some split loom to protect my wires, close up the incision, dress my metal work, prime and paint, secure the panel, seal it up, etc.

Share this post


Link to post
Share on other sites

Removed the road tar that got all over my S60 from driving I 295 in NJ. The DOT has been fixing pot holes and sealing the lane joints lately. I am glad that they are fixing the highway but getting tar all over the car sucks. I used WD40 to wipe off the crap. It really works great.

Share this post


Link to post
Share on other sites

Saff R: Replaced ECT sensor that was giving P0117 and de-blacked the B & C pillars; so much cleaner in looking in saffron.

Saff C: Tighten a loose screw that was giving an annoying rattle when listening to songs with any bass and adjusted the window, hoping the wind noise is gone now.

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this