Sign in to follow this  
scout01

What Did You Do To Your Car Today.

Recommended Posts

. And how is this??????

poking PA people are weird and retarded

Share this post


Link to post
Share on other sites

Justin's hatch on the laser is what pushed him over the edge. But I thin Adam's pizza fetish may have started it.

I drove the wagon, finally. Runs well, no more noises, issues, blah, blah, blah...

Share this post


Link to post
Share on other sites

had my EGT probe installed/hooked up and straightened out the wire for it......had a 3 month ongoing exhaust leak fixed once and for all and bought a hazard switch....stupid turn signals decided they don't want to blink anymore and the hazards dont work at all, fuse is good

Share this post


Link to post
Share on other sites

had my EGT probe installed/hooked up and straightened out the wire for it......had a 3 month ongoing exhaust leak fixed once and for all and bought a hazard switch....stupid turn signals decided they don't want to blink anymore and the hazards dont work at all, fuse is good

Your relay is stuck. Hit the dash (poo' boy fix) or pull your hazard switch and replace the relay.

Share this post


Link to post
Share on other sites

I am still trying to figure out why my coolant keeps going a hint of brown in my S70... it is still easy to look through it.. but it goes from green to brown... I am loosing a very little bit of coolant and I can not figure out why

my compression results came back all in the 200 psi across all cyl so I am scratching my head on this one

Is it auto? I wonder if the transmission cooler inside the rad has a slight crack? Just throwing it out there. I had that issue on my 855.

Share this post


Link to post
Share on other sites

QUOTE (matt b @ Apr 8 2009, 05:07 PM) <{POST_SNAPBACK}>
Your relay is stuck. Hit the dash (poo' boy fix) or pull your hazard switch and replace the relay.

That's what Tom said in PM right after I said what happened. lol

I did pay Chris for a replacement switch.....the relay is one with the switch right?

I'm gonna try the poor boy fix in the meantime.

Share this post


Link to post
Share on other sites

QUOTE (matt b @ Apr 8 2009, 05:22 PM) <{POST_SNAPBACK}>
I think so, yes.

Cool, thanks....going to try the ghetto fix til the new switch comes. lol

Share this post


Link to post
Share on other sites

Cool, thanks....going to try the ghetto fix til the new switch comes. lol

Don't break anything else beating the shit out of it. :lol:

Share this post


Link to post
Share on other sites

paint your pegs and you can join the in crowd :lol:

someones already painted theres JohnDeer Green , mine are going John Deer Yellow B)

Yeah well you know what... when I get a larger set of rims, I'm gonna paint 'em John Deere Green with a John Deere Yellow LIP!... then I'll get my friend to make me some yellow John Deere logos out of vinyl, paint the center caps JDG and apply the vinyls! EFF YEAH!

I've grown to appreciate John Deere equipement ever since my family and I took a trip out to Geneseo, IL a few weeks ago. Relatives took us around and showed us the JD Pavilion that's a few hours away from there. Pretty sweet stuff.

Share this post


Link to post
Share on other sites

That's what Tom said in PM right after I said what happened. lol

you could also call it the turbobricks way of fixing things...throw in a ziptie while your at it :lol:

Yeah well you know what... when I get a larger set of rims, I'm gonna paint 'em John Deere Green with a John Deere Yellow LIP!... then I'll get my friend to make me some yellow John Deere logos out of vinyl, paint the center caps JDG and apply the vinyls! EFF YEAH!

I've grown to appreciate John Deere equipement ever since my family and I took a trip out to Geneseo, IL a few weeks ago. Relatives took us around and showed us the JD Pavilion that's a few hours away from there. Pretty sweet stuff.

wtf. since when is everyone wanting redneck or what? :D

Share this post


Link to post
Share on other sites

QUOTE (matt b @ Apr 8 2009, 05:24 PM) <{POST_SNAPBACK}>
Don't break anything else beating the stuff out of it. :lol:

Haha, so I turned the hazards on and they started working.....tried the turns and they both work too. woot lol

you could also call it the turbobricks way of fixing things...throw in a ziptie while your at it :lol:

bahaha speaking of, im out of zipties :(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this