Sign in to follow this  
scout01

What Did You Do To Your Car Today.

Recommended Posts

My rims returned from powder coating. went and put the tires on them. Painted my BBK's lime metallic green. Installed my new to me turbo. washed it.

Share this post


Link to post
Share on other sites

drove it for the first time in over a month :wub:

forgot how much i loved 160bhp :lol:

Share this post


Link to post
Share on other sites

Friday: Drove it in rush hour :angry:

Bottomed out x2

Saturday Took out the back seat bottom and used it to sit on around a campfire :lol: ---very comfy

Sunday bottomed it out again

I cant imagine what it would have been like with ipd springs :lol:

Share this post


Link to post
Share on other sites

My rims returned from powder coating. went and put the tires on them. Painted my BBK's lime metallic green. Installed my new to me turbo. washed it.

:huh: nice we need pics :lol:

Share this post


Link to post
Share on other sites

Yesterday:

- wideband O2 bung welded in

- EGT probe installed

Today:

- wired and installed AEM wideband, Prosport EGT, Prosport BG

- mounted in 3-gauge A-pillar pod

Share this post


Link to post
Share on other sites

Installed a set of Bosch Icons. I added 2 spoilers today, so that's good for 20HP amirite? :D

Share this post


Link to post
Share on other sites

Installed a set of Bosch Icons.

put a set of those on my dads car. they seem good so far.

Share this post


Link to post
Share on other sites

-Oil change mobil 1 10w30 synth

-Conditioned leather

-

Share this post


Link to post
Share on other sites

put a set of those on my dads car. they seem good so far.

put them on your S70. they'll leave a nice big streak.

Share this post


Link to post
Share on other sites

put them on your S70. they'll leave a nice big streak.

Put them on an S60. They'll work just fine. Not our fault your wiper blades are epic fail. :)

Share this post


Link to post
Share on other sites

Put them on an S60. They'll work just fine. Not our fault your wiper blades are epic fail. :)

you're right. they work great on my dad's s60. but on an S70 - total fail.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this