• Upcoming Events

    No upcoming events found

Archived

This topic is now archived and is closed to further replies.

  • 0

Anti Skid Light On Xc 90

Question

Posted

Hello, I'm a newbie fron New Jersey with a 2004 XC 90 problem.

My message center on my dash flashed " Service needed for anti skid mechanism". Just flashed once about a month and a half ago. Just that once. This was after I turned my car on after getting gas. Flashed once for a few seconds and haven't seen it since. I have 44K miles on the car.

Took car to dealer for scheduled service (Redbank Volvo) and happened to mention this. The next thing I know the "advisor" is telling me that I need to replace my ABS Module for $1250!!

What do you guys think? Any advise?

Can someone PLEASE give me an Indy Volvo mechs in Redbank or Freehold area please.

0

Share this post


Link to post
Share on other sites

0 answers to this question

Posted

Hello, I'm a newbie fron New Jersey with a 2004 XC 90 problem.

My message center on my dash flashed " Service needed for anti skid mechanism". Just flashed once about a month and a half ago. Just that once. This was after I turned my car on after getting gas. Flashed once for a few seconds and haven't seen it since. I have 44K miles on the car.

Took car to dealer for scheduled service (Redbank Volvo) and happened to mention this. The next thing I know the "advisor" is telling me that I need to replace my ABS Module for $1250!!

What do you guys think? Any advise?

Can someone PLEASE give me an Indy Volvo mechs in Redbank or Freehold area please.

goto a parking lot and drive fairly fast and mash your breaks. This will determine the abs, then if that works drive through a corner and mash the breaks again while trying to make the car spin out or you can just take corners in the rain and see if you start to spin. If all is good, then forget about the message, it would also be helpfull to read the codes and post them (i cant tell you what the codes mean but others can).

0

Share this post


Link to post
Share on other sites

Posted

goto a parking lot and drive fairly fast and mash your breaks. This will determine the abs, then if that works drive through a corner and mash the breaks again while trying to make the car spin out or you can just take corners in the rain and see if you start to spin. If all is good, then forget about the message, it would also be helpfull to read the codes and post them (i cant tell you what the codes mean but others can).

Whew, finally got back from work and have some time to read the forums!

Thanks for the info. I did try to mash the brakes in regular weather and alls fine. I haven't spun out in the recent NJ rains either. I will try the rain thing a bit more aggressively next time.

What do you mean by codes? Where do I get them? My message center just flashes the words, no codes.

Cheers and thanks!

0

Share this post


Link to post
Share on other sites

Posted

Sounds like early symptoms of ABS unit failure. If you're only getting this once in awhile it could go for quite some time. If you start getting this with ABS failure lights, it close to gone.

0

Share this post


Link to post
Share on other sites

Posted

NO its not the abs its your YAW sensor its under the passenger seat and u will find water under the carpet which is what made the YAW sensor go bad this past spring ive replaced 10 YAW sensors with the same problem

0

Share this post


Link to post
Share on other sites

Posted

NO its not the abs its your YAW sensor its under the passenger seat and u will find water under the carpet which is what made the YAW sensor go bad this past spring ive replaced 10 YAW sensors with the same problem

Possible cause, I've seen quite a few replaced. Call and talk with the service manager to see if they are sure $1300 will fix the car. If it dosen't you have lots of leverage.

0

Share this post


Link to post
Share on other sites

Posted

Maybe I'm dumb, but how is a 2004 not under warranty still? Or do the US models not have a 4 year warranty?

0

Share this post


Link to post
Share on other sites

Posted

you are still under warranty if u have 44k on your car and its an 04 ............ and im 99% sure that its the YAW sensor if u can get me the code i can let you know 100 % what it is

0

Share this post


Link to post
Share on other sites

Posted

NO its not the abs its your YAW sensor its under the passenger seat and u will find water under the carpet which is what made the YAW sensor go bad this past spring ive replaced 10 YAW sensors with the same problem

I have an 04 xc90 with 40k miles. My wife spilt her water bottle on the passenger floor. Week later "anti skid service reqiured" Brakes work fine. I have heard that it my be the yaw sensor. The text window also displays 023. I'm the second owner so no warranty. I'm very mechanically inclined, is this something I can fix?

0

Share this post


Link to post
Share on other sites

Posted

Thanks for all the input guys.

I haven't spilled any water. Heavy rains thats all. Will that do it? The dampness and some water that creeps in? LOTS of carwashes though- the ones where they make you get out of the car. Maybe those guys did some spillage and cleaned it up..I will look into it.

Where do the codes show up? I am NOT getting any codes whatsoever or any ABS failure text at all after that one time. It was JUST that one time about 2 months ago......... :( . I feel so frustrated and stupid........

I mean if the ABS module is a problem, shouldn't I be getting text and codes in my message window????? Wouldn't my brakes squeak or slip or something?? WHAT am I supposed to experience in a true ABS failure?????? HELP!!

The warranty expired in July I'm being told since we bought the car in Sept of 2003- it is technically a 2004 though. The warranty is for 4 yrs or 4K whichever comes 1st is what I know.

0

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.