Hussein's 1998 V70 Xr : The Force Awakens


Recommended Posts

Like the others say..

Spark makes no sense

Lambda makes no sense

Basically nothing makes sense.

Don't go 100% on what the Innovate says. I have had similar experience assuming a new LC-1 was OK yet it was faulty. The OT-1 simply sucks.

Any other OBD tools to see what the lambda and timing does?

OK. Well since the car runs very well overall, something must make sense :lol:

The AFR data is pulled from my AEM wideband, not from OBDII. I can try an alternate OBDII tester, but it doesn't have data logging capabilities.

I drove the car with a Volvo fuel pressure tester taped to my windshield today, and the pressure does not deviate under WOT conditions.

Having said that, at two points the fuel cut, I saw it blip on the gauge, and I was nowhere near the RPM limit. I thought it was spark blowout, but the pressure definitely blipped momentarily at the points where the TPS % (last column) dropped.

Link to post
Share on other sites
  • Replies 3.4k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

This is nuts, I blame the site update for the failure.

I'll take some over the weekend this morning:

Thanks, Robbie. I'm going to run 10mm ID line F/R, using AN -08 fittings from the pumps through the filter, with ORB-06 fittings for the returns.I was looking at fuel filters - I was going to use

Posted Images

Somebody had said that WI makes the mix richer. Not my understanding. So, I did data logs with and without. As expected, with makes for a leaner mix, since you're adding unmetered oxygen. The methyl-alcohol component in washer fluid is obviously not enough to make any difference.

Link to post
Share on other sites

Still doesn't make sense :( WI doesn't add any unmetered oxygen..you're not breaking the water down into H and O2 (thank god) and all the air came past the MAF. The one where it runs lean, its also showing much higher boost? In fact, I don't understand why the car would run at all at WOT with such figures. Last night I drove the 850 and although it rips with 12.0, it already starts to stumble around 12.5-12.6 AFR and goes berserk at 13:1 AFR. Trust me, those are not good AFR's.

Perhaps the most puzzling part of this is why are you continuing to mess with this ECU which is never going to give you a clean AFR when you have another you can program yourself to deliver a nice steady AFR away from the silly lean that you're doing now.

I'll bet the house that your car is not accelerating as well as it should with 13.5 AFFR's up top.

Link to post
Share on other sites

Perhaps the most puzzling part of this is why are you continuing to mess with this ECU which is never going to give you a clean AFR when you have another you can program yourself to deliver a nice steady AFR away from the silly lean that you're doing now.

I'll bet the house that your car is not accelerating as well as it should with 13.5 AFFR's up top.

If he insists the car is running well it could mean two things...

Either we are still looking for Joe or the numbers are simply wrong.

Boost at 1.45, AFR well in the 13's and a timing of 6 degree doesn't do anything.

There simply is no grunt.

If you like it this way than I would suggest to lower boost to 0.9 with a lot more timing. Car will probably be a whole lot faster.

Time to pop in that TT and start from scratch.

Link to post
Share on other sites

Still doesn't make sense :( WI doesn't add any unmetered oxygen..you're not breaking the water down into H and O2 (thank god) and all the air came past the MAF. The one where it runs lean, its also showing much higher boost? In fact, I don't understand why the car would run at all at WOT with such figures. Last night I drove the 850 and although it rips with 12.0, it already starts to stumble around 12.5-12.6 AFR and goes berserk at 13:1 AFR. Trust me, those are not good AFR's.

Perhaps the most puzzling part of this is why are you continuing to mess with this ECU which is never going to give you a clean AFR when you have another you can program yourself to deliver a nice steady AFR away from the silly lean that you're doing now.

I'll bet the house that your car is not accelerating as well as it should with 13.5 AFFR's up top.

Hi

Thanks for the input

The car ran like shit with the WI under high load.

The reason I'm still messing with it is simply because I want to get Janne to fix it. I can't really get that if I can't clearly state what is off. Basically, it needs a lower target AFR for everything over around 54-5600rpm, correct?

I also want to dyno with both tunes, for comparison. I guess at this point, Janne's tune isn't going to improve with any alterations I can make.

Yes, the car is not accelerating as well as it should up top, you can feel it.

Time to start with TT. I've been putting it off in part because the weather here now is crap.

If he insists the car is running well it could mean two things...

Either we are still looking for Joe or the numbers are simply wrong.

1 Boost at 1.45, AFR well in the 13's and a timing of 6 degree doesn't do anything.

There simply is no grunt.

If you like it this way than I would suggest to lower boost to 0.9 with a lot more timing. Car will probably be a whole lot faster.

2 Time to pop in that TT and start from scratch.

1. I agree.

2. Yes indeed :D

Link to post
Share on other sites

started the basic TT mapping

base 550cc calibration

data logged preliminary calibration - too lean over 42% range - reset levels somewhat

have to wait until the roads are dry again to check.

This is the base timing map

I'll datalog tomorrow, and see where the timing is ending up under road conditions.

Link to post
Share on other sites

Where did that timing map come from? It looks all over the place! May be the worst I've ever seen lol

Your main fuel map looks a little low to me, is that the stock MAF or a bigger housing? Keep in mind that after a reset it will usually be too rich untill it learns. No point making it leaner while it's still adapting or you'll just get a CEL later on.

Link to post
Share on other sites

Where did that timing map come from? It looks all over the place! May be the worst I've ever seen lol

Your main fuel map looks a little low to me, is that the stock MAF or a bigger housing? Keep in mind that after a reset it will usually be too rich untill it learns. No point making it leaner while it's still adapting or you'll just get a CEL later on.

That timing map is the one that came with the tune.

Stock MAF in stock housing.

I've been enrichening the map over 42%, not leaning it, it's too lean down ther, never mind @ WOT

Link to post
Share on other sites

in 4th, still too lean over 5K. Have to enrichen the map some more. There is a WOT scale also, but it's still too lean well below full throttle. Boost scale is underreporting by .3Kg/cm2

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.