Anyone know how to get the black cover off od the ABD pump (not module) on a P80?


Recommended Posts

Swapped out the abs module and when I did the two power wires that go to the pump stripped themselves bare.  I need to get the black cover off the pump to recover the wires but cant figure out how its fastened.  Please let me know if you know.

 

Gary

abs.jpg

Link to post
Share on other sites

Unfortunately the thread while helpful doesnt explain how the black cover comes off.  I have pried everywhere I can but not knowing how it attaches is a huge disadvantage.  I am confidant it is not the module as I just last week replaced it with a Mattymoo special.  ;)

 

Link to post
Share on other sites

You know it's been so long I don't recall exactly how, or if, I got the cover completely off.  Maybe I cut it off and siliconed it back together, or maybe I just cut the two wires near the connector and slid shrink tube over the individual wires as far up under the cover as I could, and then soldered them back to the connector.  :unsure:

Will take a look at it later today to see if I can remember...  [update: I think I did the latter of above; cover appears to be intact]

You may want to ping @Matty Moo himself, as he would know for sure.  He mentions in that thread moving the wire harness (above the pump motor) out of the way to get the cover off.

 

12 hours ago, Yellow95 said:

but not knowing how it attaches is a huge disadvantage

IIRC it just snaps onto something at the base, so kind of run a bone tool or small thin screwdriver around the base of the cover should release it.  BTW the cover on my 96 855 is plastic (this is the one I had to repair) but noticed the one on the 98 S70 GLT appears to be steel.  Which is yours?

Edited by gdog
Link to post
Share on other sites

lol - i remember asking about this too 

i wound up neatly cutting it off - i forget what i uncovered when i removed it and how it was fastened.

Link to post
Share on other sites
19 hours ago, gmsgltr said:

lol - i remember asking about this too 

i wound up neatly cutting it off - i forget what i uncovered when i removed it and how it was fastened.

Exactly what I did.  Then wrapped the wires and gorilla taped it back together.  Light went out immediately.  Thank baby Jesus.

Link to post
Share on other sites

yup did the same lol 

i have been too lazy to even go to the garage and look at what i did years ago. i will. soon enough.

glad its fixed!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.