What Did You Do To Your Car Today.


Recommended Posts

  • Replies 24.5k
  • Created
  • Last Reply

Top Posters In This Topic

  • matt b

    1494

  • 7 VII 7

    1133

  • Oreo931

    1091

  • Chilled man

    1062

Top Posters In This Topic

Popular Posts

no because you cannot mesh T5 and Pole... too much of a "stretch" if you said "waxed my rocket" that would have been better

What are you raising it to?? I'm just throwing the MBC wide open. (Worse case, the ECU will get pissed and fuel-cut, but the tune should fix that.) I'm really interested to see how far that 15G can

Started it. Drove it.

Posted Images

Try seafoam in a vacuum line and crankcase? That helped for me....I took half a can in through a vacuum line, smoked like a mofo for a little and that really made a difference. I took the other half can and added it to my engine oil ~15 miles before I changed my oil.....in my opinion that made a little difference in the age progressing motor noise.

Also on topic I gapped my plugs down to .024 and dialed boost down a bit....seems to be pulling smooth now.

Would that help if it were my lifters? From what I have read, the noise could be indicative of stuck lifters OR oil seal O rings or something of that nature going bad.

Link to post
Share on other sites

Would that help if it were my lifters? From what I have read, the noise could be indicative of stuck lifters OR oil seal O rings or something of that nature going bad.

If there's grime, etc. making your lifters stick a bit Seafoam would be a good thing to try...at least in my opinion.

Link to post
Share on other sites

Would that help if it were my lifters? From what I have read, the noise could be indicative of stuck lifters OR oil seal O rings or something of that nature going bad.

Danny, do not put seafoam into your crankcase.

Sorry Aaron, but that was a poor decision.

Take a video of the noise.

Link to post
Share on other sites

pulled the battery to charge it, again.

Haven't driven it in like 2 weeks. and the day i need it, it's dead.

Link to post
Share on other sites

Washed it.....gonna go detail the interior and condition the seats and shampoo floor mats.....I'd clean my engine bay but it's already purty. lol

Hopefully delivery man brings me my SAS check valve from Waltrip and then I can throw in that and the new pump and get rid of this god forsaken CEL.

Link to post
Share on other sites

does anyone know why my car vibrates and rumbles when starting up in the cold in the morning... I feel the pulse in my brakes and steering wheel and just sounds like it is about to shut off... this is when it is in P and in gear... but not N

Link to post
Share on other sites

does anyone know why my car vibrates and rumbles when starting up in the cold in the morning... I feel the pulse in my brakes and steering wheel and just sounds like it is about to shut off... this is when it is in P and in gear... but not N

Lower right hand side engine mount

Link to post
Share on other sites

Lower right hand side engine mount

hmm... last time I checked it was fine... it is 188k miles old

I thought it might have been the transmission fluid needed changing? It is getting on the burnt side... but not sure

anymore info on why this would be the crank side engine mount Danny?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.